summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebRmv2018-05-16 16:57:53 +0200
committerSebRmv2018-05-16 16:59:48 +0200
commit576801cabe17af2db799705b262155f96be47976 (patch)
treee4926855119779aa64ccce1e7367b8814d805340
parenteb3191096d43cb362fcf951d6a0a07c5f4189ecd (diff)
downloadaur-576801cabe17af2db799705b262155f96be47976.tar.gz
Fix (do not copy symbolic links).
-rw-r--r--.SRCINFO4
-rw-r--r--Makefile3
-rw-r--r--PKGBUILD6
3 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0acbe5464fbd..ff1c42c15ecb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ia32_aout-dkms
pkgdesc = ia32_aout kernel module, for running an a.out binary format (DKMS)
pkgver = 4.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.kernel.org
arch = x86_64
license = GPLv3
@@ -13,7 +13,7 @@ pkgbase = ia32_aout-dkms
source = Makefile
source = dkms.conf
sha1sums = c635114660009c57014eb2a38e50e3abbb5f2e5f
- sha1sums = 615a88c88babaaa0a254a402bd359d52406c1cdb
+ sha1sums = 0917bffa1791e7004e85b75e76a191d058d023d8
sha1sums = 42244650cd11033033f49a7909e5825584afd0cb
pkgname = ia32_aout-dkms
diff --git a/Makefile b/Makefile
index a816299372bf..a8e4221bab40 100644
--- a/Makefile
+++ b/Makefile
@@ -5,3 +5,6 @@ PWD := $(shell pwd)
all:
$(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
+.PHONY: clean
+
+clean:
diff --git a/PKGBUILD b/PKGBUILD
index 47573518bad7..72686b3cd4e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgbase=ia32_aout
pkgname=ia32_aout-dkms
pkgver=4.0
-pkgrel=1
+pkgrel=2
pkgdesc='ia32_aout kernel module, for running an a.out binary format (DKMS)'
arch=('x86_64')
depends=('dkms')
@@ -16,7 +16,7 @@ source=("https://raw.githubusercontent.com/torvalds/linux/v{$pkgver}/arch/x86/ia
'dkms.conf')
# updpkgsums
sha1sums=('c635114660009c57014eb2a38e50e3abbb5f2e5f'
- '615a88c88babaaa0a254a402bd359d52406c1cdb'
+ '0917bffa1791e7004e85b75e76a191d058d023d8'
'42244650cd11033033f49a7909e5825584afd0cb')
package() {
@@ -24,7 +24,7 @@ package() {
install -Dm644 dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
# Copy sources (including Makefile)
- cp -a ia32_aout.c Makefile dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/
+ cp ia32_aout.c Makefile dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/
# Set name and version
sed -e "s/@_PKGBASE@/${_pkgbase}/" \