summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-06-12 19:26:23 -0700
committerxiota2023-06-12 19:26:23 -0700
commitdf7715247afad9f3014ed2a7259e9fe58888927d (patch)
tree5d2e134b53e1ac68df0f041826c1155a18975f4f
parentbf06ad85019daf31fdb0f1c0340bda473610ee90 (diff)
downloadaur-ialauncher-git.tar.gz
patch to use user xdg cache dir
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD34
2 files changed, 30 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8aa5a055c9c0..cc7935752996 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,8 +10,13 @@ pkgbase = ialauncher-git
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
+ depends = dosbox
depends = python-pygame
+ depends = python-pyxdg
+ options = !strip
source = ialauncher::git+https://github.com/rtts/ialauncher
+ source = ialauncher-19-xdg-cache.patch::https://github.com/rtts/ialauncher/pull/19.patch
sha256sums = SKIP
+ sha256sums = 6def4ff58722dc5efbbd93c19837bb80774bb2d979a69567279273a4e0a4dc5b
pkgname = ialauncher-git
diff --git a/PKGBUILD b/PKGBUILD
index c4efdf7ede66..5ec930922f3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,15 +9,11 @@ pkgdesc='Play all of the Internet Archive’s MS-DOS games offline'
arch=('any')
url='https://github.com/rtts/ialauncher'
license=('GPL3')
+
depends=(
+ 'dosbox'
'python-pygame'
-
- # Not needed?
- #'dosbox'
- #'gst-plugins-bad'
- #'python-jinja'
- #'python-natsort'
- #'webkit2gtk'
+ 'python-pyxdg'
)
makedepends=(
'git'
@@ -26,8 +22,28 @@ makedepends=(
'python-setuptools'
'python-wheel'
)
-source=("$_pkgname"::"git+$url")
-sha256sums=('SKIP')
+
+options=(!strip)
+
+source=(
+ "$_pkgname"::"git+$url"
+ "ialauncher-19-xdg-cache.patch"::"https://github.com/rtts/ialauncher/pull/19.patch"
+)
+sha256sums=(
+ 'SKIP'
+ '6def4ff58722dc5efbbd93c19837bb80774bb2d979a69567279273a4e0a4dc5b'
+)
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ for patch in "$srcdir"/*.patch ; do
+ if [ -f "$patch" ] ; then
+ echo "Applying patch: ${patch##*/}"
+ patch -Np1 -F100 -i "$patch"
+ fi
+ done
+}
pkgver() {
cd "$srcdir/$_pkgname"