summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn-Gee2019-10-23 00:43:07 -0700
committerJohn-Gee2019-10-23 00:43:07 -0700
commit4d276a093578a577f61314564d47c4855682122a (patch)
tree02687acc3d272f7f9b7a89ff3b16ecc5644e3332
parent8b597b886e8f5b63c71022b62afb5b02a21a94af (diff)
downloadaur-4d276a093578a577f61314564d47c4855682122a.tar.gz
Made changes suggested by yochananmarqos
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
-rw-r--r--gamespath.patch11
3 files changed, 11 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82e78f3bdb6c..78ed7563f37d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ialauncher-git
pkgdesc = Play all of the Internet Archive’s MS-DOS games offline!
- pkgver = 1
- pkgrel = 2
+ pkgver = r45.291048f
+ pkgrel = 1
url = https://github.com/rtts/ialauncher
arch = x86_64
license = GPL3
@@ -12,9 +12,7 @@ pkgbase = ialauncher-git
depends = gst-plugins-bad
depends = python-jinja
source = ialauncher::git+https://github.com/rtts/ialauncher.git
- source = gamespath.patch
sha256sums = SKIP
- sha256sums = 3d1fc7b7ad96bcbeb2f3a8331df7c157c9720c4f3c685715cba0aa1a98a2c166
pkgname = ialauncher-git
diff --git a/PKGBUILD b/PKGBUILD
index 3edb51c3a5d0..85936b014ef8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,22 @@
# Maintainer: gee
pkgname=ialauncher-git
-pkgver=1
-pkgrel=2
+pkgver=r45.291048f
+pkgrel=1
pkgdesc='Play all of the Internet Archive’s MS-DOS games offline!'
arch=('x86_64')
url='https://github.com/rtts/ialauncher'
license=('GPL3')
depends=('dosbox' 'webkit2gtk' 'python' 'python-natsort' 'gst-plugins-bad'
'python-jinja')
-source=('ialauncher::git+https://github.com/rtts/ialauncher.git'
- 'gamespath.patch')
-sha256sums=('SKIP'
- '3d1fc7b7ad96bcbeb2f3a8331df7c157c9720c4f3c685715cba0aa1a98a2c166')
+source=('ialauncher::git+https://github.com/rtts/ialauncher.git')
+sha256sums=('SKIP')
-# no tags yet
-#pkgver() {
-# cd ialauncher
-
-# git describe | sed 's/-/.r/; s/-g/./'
-#}
-
-#prepare() {
-# cd ialauncher
+pkgver() {
+ cd ialauncher
-# patch -Np1 -i "${srcdir}/gamespath.patch"
-#}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
cd ialauncher
@@ -36,7 +27,5 @@ build() {
package() {
cd ialauncher
- python setup.py install --root="$pkgdir"
- #install -dm 755 "${pkgdir}/opt/ialauncher/"
- #cp -r games "${pkgdir}/opt/ialauncher/"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
diff --git a/gamespath.patch b/gamespath.patch
deleted file mode 100644
index 2f4762e7d7d6..000000000000
--- a/gamespath.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/bin/ialauncher
-+++ b/bin/ialauncher
-@@ -4,7 +4,7 @@
- from ialauncher.backend import Backend
- from ialauncher.frontend import Frontend
-
--games_dir= os.path.join(os.path.expanduser("~"), 'games')
-+games_dir= '/opt/ialauncher/games'
- if not os.path.isdir(games_dir):
- print('''
- Error: the games directory could not be found at {}