summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël PORTAY2022-06-24 06:02:32 +0200
committerGaël PORTAY2022-06-25 05:59:51 +0200
commit0c15323ef58bc4cc0205765b76d29b06e5eb6e4d (patch)
tree3274d81936b2b00f5a8037e511af0463e6b99ea3
parentb443dd78f29739a6b9f4967ebda47d109cdb9b25 (diff)
downloadaur-0c15323ef58bc4cc0205765b76d29b06e5eb6e4d.tar.gz
v5
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD49
2 files changed, 47 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62174be1fb60..7ec99c6c0e11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,26 @@
pkgbase = iamroot
pkgdesc = Emulating the syscall chroot(2) in an unpriviliged process
- pkgver = 4
+ pkgver = 5
pkgrel = 1
url = https://github.com/gportay/iamroot
arch = x86_64
license = GPL
checkdepends = shellcheck
- makedepends = aarch64-linux-gnu-gcc
- makedepends = aarch64-linux-musl
+ makedepends = lib32-glibc
+ makedepends = i386-musl
+ makedepends = kernel-headers-musl-i386
makedepends = musl
makedepends = kernel-headers-musl
+ makedepends = armhf-musl
+ makedepends = kernel-headers-musl-armhf
+ makedepends = aarch64-linux-musl
+ makedepends = aarch64-linux-gnu-gcc
makedepends = kernel-headers-musl-aarch64
+ makedepends = git
makedepends = asciidoctor
- source = https://github.com/gportay/iamroot/archive/v4.tar.gz
+ options = !strip
+ source = https://github.com/gportay/iamroot/archive/v5.tar.gz
validpgpkeys = 8F3491E60E62695ED780AC672FA122CA0501CA71
- sha256sums = 5259508a3d34caa8bffc6cf125027c37bca86fb78fd8011cacd646fcb13ff681
+ sha256sums = 2a8cd0f8bf8386622d943835f81a91c10766ba416ce8d5665ccd6b6150de8a8c
pkgname = iamroot
diff --git a/PKGBUILD b/PKGBUILD
index e57ac735fc57..61b73abb1beb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,47 @@
# Maintainer: Gaël PORTAY <gael.portay@gmail.com>
pkgname=iamroot
-pkgver=4
+pkgver=5
pkgrel=1
pkgdesc='Emulating the syscall chroot(2) in an unpriviliged process'
arch=('x86_64')
url="https://github.com/gportay/$pkgname"
license=('GPL')
-makedepends=('aarch64-linux-gnu-gcc' 'aarch64-linux-musl' 'musl' 'kernel-headers-musl' 'kernel-headers-musl-aarch64' 'asciidoctor')
+makedepends=('lib32-glibc'
+ 'i386-musl'
+ 'kernel-headers-musl-i386'
+ 'musl'
+ 'kernel-headers-musl'
+ 'armhf-musl'
+ 'kernel-headers-musl-armhf'
+ 'aarch64-linux-musl'
+ 'aarch64-linux-gnu-gcc'
+ 'kernel-headers-musl-aarch64'
+ 'git'
+ 'asciidoctor')
checkdepends=('shellcheck')
+options=('!strip')
source=("https://github.com/gportay/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('5259508a3d34caa8bffc6cf125027c37bca86fb78fd8011cacd646fcb13ff681')
+sha256sums=('2a8cd0f8bf8386622d943835f81a91c10766ba416ce8d5665ccd6b6150de8a8c')
validpgpkeys=('8F3491E60E62695ED780AC672FA122CA0501CA71')
prepare() {
cd "$pkgname-$pkgver"
+ ln -sf support/makefile
touch local.mk
}
build() {
cd "$pkgname-$pkgver"
- make -f support/makefile x86_64/libiamroot-linux-x86-64.so.2
- make -f support/makefile x86_64/libiamroot-musl-x86_64.so.1
- make CFLAGS= -f support/makefile aarch64/libiamroot-linux-aarch64.so.1
- make CFLAGS= -f support/makefile aarch64/libiamroot-musl-aarch64.so.1
- make -f support/makefile doc
+ make i686/libiamroot-linux.so.2
+ make i686/libiamroot-musl-i386.so.1
+ make x86_64/libiamroot-linux-x86-64.so.2
+ make x86_64/libiamroot-musl-x86_64.so.1
+ make CFLAGS= armhf/libiamroot-linux-armhf.so.3
+ make CFLAGS= armhf/libiamroot-musl-armhf.so.1
+ make CFLAGS= aarch64/libiamroot-linux-aarch64.so.1
+ make CFLAGS= aarch64/libiamroot-musl-aarch64.so.1
+ make doc
}
check() {
@@ -34,11 +51,15 @@ check() {
package() {
cd "$pkgname-$pkgver"
- make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-exec-x86_64-linux-x86-64.2
- make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-exec-x86_64-musl-x86_64.1
- make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-exec-aarch64-linux-aarch64.1
- make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-exec-aarch64-musl-aarch64.1
- make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-doc
- make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-bash-completion
+ make PREFIX=/usr DESTDIR="$pkgdir" install-exec-i686-linux.2
+ make PREFIX=/usr DESTDIR="$pkgdir" install-exec-i686-musl-i386.1
+ make PREFIX=/usr DESTDIR="$pkgdir" install-exec-x86_64-linux-x86-64.2
+ make PREFIX=/usr DESTDIR="$pkgdir" install-exec-x86_64-musl-x86_64.1
+ make PREFIX=/usr DESTDIR="$pkgdir" install-exec-aarch64-linux-aarch64.1
+ make PREFIX=/usr DESTDIR="$pkgdir" install-exec-aarch64-musl-aarch64.1
+ make PREFIX=/usr DESTDIR="$pkgdir" install-exec-armhf-linux-armhf.3
+ make PREFIX=/usr DESTDIR="$pkgdir" install-exec-armhf-musl-armhf.1
+ make PREFIX=/usr DESTDIR="$pkgdir" install-doc
+ make PREFIX=/usr DESTDIR="$pkgdir" install-bash-completion
install -D -m 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}