summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël PORTAY2021-05-05 11:30:01 -0400
committerGaël PORTAY2021-05-06 12:19:09 -0400
commit2414bd46b6e3df8831f7c2c1399e2ab2359ecbab (patch)
tree2b2fc9d2c052d9a0d8c2a3cab8a972dd32aeb409
downloadaur-2414bd46b6e3df8831f7c2c1399e2ab2359ecbab.tar.gz
v1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5098b941ef0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = iamroot
+ pkgdesc = Emulating syscall chroot in an unpriviliged process
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/gportay/iamroot
+ arch = x86_64
+ license = GPL
+ makedepends = asciidoctor
+ source = https://github.com/gportay/iamroot/archive/v1.tar.gz
+ sha256sums = 96105f40d8c94b4bdaf8edff0bacd22a5609a6db0388b8dda3c930d38dc60d46
+
+pkgname = iamroot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a29cd0b0fe0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gaël PORTAY <gael.portay@gmail.com>
+
+pkgname=iamroot
+pkgver=1
+pkgrel=1
+pkgdesc='Emulating syscall chroot in an unpriviliged process'
+arch=('x86_64')
+url="https://github.com/gportay/$pkgname"
+license=('GPL')
+makedepends=('asciidoctor')
+source=("https://github.com/gportay/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('96105f40d8c94b4bdaf8edff0bacd22a5609a6db0388b8dda3c930d38dc60d46')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make libiamroot.so doc
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+}