summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël PORTAY2021-12-03 03:09:08 +0100
committerGaël PORTAY2021-12-31 20:40:58 +0100
commit2f47431ddd0230d6f113432d768fb361a395c7cd (patch)
treed6e800454b6378a8352e31236e14efe5d2e36c50
parent2414bd46b6e3df8831f7c2c1399e2ab2359ecbab (diff)
downloadaur-2f47431ddd0230d6f113432d768fb361a395c7cd.tar.gz
v2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5098b941ef0a..f3f835eddbb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = iamroot
pkgdesc = Emulating syscall chroot in an unpriviliged process
- pkgver = 1
+ pkgver = 2
pkgrel = 1
url = https://github.com/gportay/iamroot
arch = x86_64
license = GPL
makedepends = asciidoctor
- source = https://github.com/gportay/iamroot/archive/v1.tar.gz
- sha256sums = 96105f40d8c94b4bdaf8edff0bacd22a5609a6db0388b8dda3c930d38dc60d46
+ source = https://github.com/gportay/iamroot/archive/v2.tar.gz
+ sha256sums = 53c0dbe9f4cce563af4ab7116c7aa9889801d9c5b82881bb1ec04e9f99b2a8a8
pkgname = iamroot
-
diff --git a/PKGBUILD b/PKGBUILD
index 1a29cd0b0fe0..d6ef15a4e1f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gaël PORTAY <gael.portay@gmail.com>
pkgname=iamroot
-pkgver=1
+pkgver=2
pkgrel=1
pkgdesc='Emulating syscall chroot in an unpriviliged process'
arch=('x86_64')
@@ -9,11 +9,11 @@ url="https://github.com/gportay/$pkgname"
license=('GPL')
makedepends=('asciidoctor')
source=("https://github.com/gportay/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('96105f40d8c94b4bdaf8edff0bacd22a5609a6db0388b8dda3c930d38dc60d46')
+sha256sums=('53c0dbe9f4cce563af4ab7116c7aa9889801d9c5b82881bb1ec04e9f99b2a8a8')
build() {
cd "$pkgname-$pkgver"
- make libiamroot.so doc
+ make CFLAGS= libiamroot.so doc
}
check() {
@@ -24,4 +24,5 @@ check() {
package() {
cd "$pkgname-$pkgver"
make install PREFIX=/usr DESTDIR="$pkgdir"
+ install -D -m755 exec.sh "$pkgdir/usr/lib/iamroot/exec.sh"
}