summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaël PORTAY2022-04-25 10:08:37 +0200
committerGaël PORTAY2022-04-25 16:21:39 +0200
commitb443dd78f29739a6b9f4967ebda47d109cdb9b25 (patch)
tree1f5da14d364b9de54cdaf29edf1500fe15a71fde
parentc7b368fdd55e545dde5cf93bebdaa274a1da43f6 (diff)
downloadaur-b443dd78f29739a6b9f4967ebda47d109cdb9b25.tar.gz
v4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b0cbc0dad28..62174be1fb60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = iamroot
pkgdesc = Emulating the syscall chroot(2) in an unpriviliged process
- pkgver = 3
+ pkgver = 4
pkgrel = 1
url = https://github.com/gportay/iamroot
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = iamroot
makedepends = kernel-headers-musl
makedepends = kernel-headers-musl-aarch64
makedepends = asciidoctor
- source = https://github.com/gportay/iamroot/archive/v3.tar.gz
+ source = https://github.com/gportay/iamroot/archive/v4.tar.gz
validpgpkeys = 8F3491E60E62695ED780AC672FA122CA0501CA71
- sha256sums = 1fca9ed4e7f30b231635da07554012ec1e3278696841a38079a233f7865436cd
+ sha256sums = 5259508a3d34caa8bffc6cf125027c37bca86fb78fd8011cacd646fcb13ff681
pkgname = iamroot
diff --git a/PKGBUILD b/PKGBUILD
index b7c199a11c46..e57ac735fc57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gaël PORTAY <gael.portay@gmail.com>
pkgname=iamroot
-pkgver=3
+pkgver=4
pkgrel=1
pkgdesc='Emulating the syscall chroot(2) in an unpriviliged process'
arch=('x86_64')
@@ -10,18 +10,21 @@ license=('GPL')
makedepends=('aarch64-linux-gnu-gcc' 'aarch64-linux-musl' 'musl' 'kernel-headers-musl' 'kernel-headers-musl-aarch64' 'asciidoctor')
checkdepends=('shellcheck')
source=("https://github.com/gportay/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('1fca9ed4e7f30b231635da07554012ec1e3278696841a38079a233f7865436cd')
+sha256sums=('5259508a3d34caa8bffc6cf125027c37bca86fb78fd8011cacd646fcb13ff681')
validpgpkeys=('8F3491E60E62695ED780AC672FA122CA0501CA71')
prepare() {
cd "$pkgname-$pkgver"
- ln -sf support/makefile
touch local.mk
}
build() {
cd "$pkgname-$pkgver"
- make CFLAGS= libiamroot-linux-aarch64.so libiamroot-musl-aarch64.so libiamroot-musl-x86_64.so libiamroot-linux-x86-64.so libiamroot.so doc
+ make -f support/makefile x86_64/libiamroot-linux-x86-64.so.2
+ make -f support/makefile x86_64/libiamroot-musl-x86_64.so.1
+ make CFLAGS= -f support/makefile aarch64/libiamroot-linux-aarch64.so.1
+ make CFLAGS= -f support/makefile aarch64/libiamroot-musl-aarch64.so.1
+ make -f support/makefile doc
}
check() {
@@ -31,11 +34,11 @@ check() {
package() {
cd "$pkgname-$pkgver"
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec-musl-x86_64
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec-linux-aarch64
- make PREFIX=/usr DESTDIR="$pkgdir" install-exec-musl-aarch64
- make PREFIX=/usr DESTDIR="$pkgdir" install-doc
- make PREFIX=/usr DESTDIR="$pkgdir" install-bash-completion
+ make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-exec-x86_64-linux-x86-64.2
+ make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-exec-x86_64-musl-x86_64.1
+ make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-exec-aarch64-linux-aarch64.1
+ make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-exec-aarch64-musl-aarch64.1
+ make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-doc
+ make PREFIX=/usr DESTDIR="$pkgdir" -f support/makefile install-bash-completion
install -D -m 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}