summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2018-03-25 23:32:14 +0200
committerDavid Runge2018-03-25 23:32:14 +0200
commit478061febebd4f228b41e02e70f55dbca00d16fd (patch)
tree7c3900ea74c8502a9bb3e80273abfa3183be3cde
parent98c59f119a87e3990ecbb892f44d833da8bc5b7c (diff)
downloadaur-478061febebd4f228b41e02e70f55dbca00d16fd.tar.gz
PKGBUILD: Adding a set of patches to fix the desktop file, defeault locations for examples, patches and tools.
Installing examples, patches and tools.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--desktop.patch23
-rw-r--r--fix_paths.patch16
-rw-r--r--fix_spelling_errors.patch39
-rw-r--r--privacy.patch15
6 files changed, 120 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 921fad8c9623..8f779e76b635 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,15 @@ pkgbase = iannix
depends = glu
depends = qt5-script
source = iannix-0.9.20b.tar.gz::https://github.com/buzzinglight/iannix/archive/v0.9.20-b.tar.gz
+ source = desktop.patch
+ source = fix_paths.patch
+ source = fix_spelling_errors.patch
+ source = privacy.patch
sha512sums = 9c46250bce9550abc4ece11720616f217513aefd62a7144f7aebdaf2e11b938dc2a551d066b748089bafffd8f7d9659e8b79f6318e250e522cf608f861951c90
+ sha512sums = fb4a64ac67ddf79ba7e9caaefebb570fcdfcb8321a77de62a37759f241036ac45c6dbde26907880f19bfef784417eec13b8b8c5bebfdb25c30bd5a2d50d1b00e
+ sha512sums = ec8bffcea7468e3a41a9f110f9a7a2e875b20015db35e884d47e6a21f6d90a87d560e6ed3e73aeacdf9ac98f7cff28d1e8d1ccba1130b2a569a47a416149353a
+ sha512sums = 4f869a73813fc37106203aed9b3938ae6f5f53cad7322f71fba44a047c32ab93f8b4fdef65804b1f63f7f26781e2505672b553ee7c9baddb82f01bdc36f870f3
+ sha512sums = 88f40ff54f8c50f6b07e2620dd5029686e2d6868f908038903384e845c6a81edc346eae73cf1d1777d6709b78723bcc52cccb1f6707e1d17b2162001e8903c0c
pkgname = iannix
diff --git a/PKGBUILD b/PKGBUILD
index 7bedb9576fdf..401b16ac52e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,11 +10,24 @@ license=('GPL')
groups=('pro-audio')
depends=('alsa-lib' 'gdk-pixbuf2' 'glu' 'qt5-script')
makedepends=('qt5-tools')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/buzzinglight/${pkgname}/archive/v${pkgver/b/-b}.tar.gz")
-sha512sums=('9c46250bce9550abc4ece11720616f217513aefd62a7144f7aebdaf2e11b938dc2a551d066b748089bafffd8f7d9659e8b79f6318e250e522cf608f861951c90')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/buzzinglight/${pkgname}/archive/v${pkgver/b/-b}.tar.gz"
+ 'desktop.patch'
+ 'fix_paths.patch'
+ 'fix_spelling_errors.patch'
+ 'privacy.patch')
+sha512sums=('9c46250bce9550abc4ece11720616f217513aefd62a7144f7aebdaf2e11b938dc2a551d066b748089bafffd8f7d9659e8b79f6318e250e522cf608f861951c90'
+ 'fb4a64ac67ddf79ba7e9caaefebb570fcdfcb8321a77de62a37759f241036ac45c6dbde26907880f19bfef784417eec13b8b8c5bebfdb25c30bd5a2d50d1b00e'
+ 'ec8bffcea7468e3a41a9f110f9a7a2e875b20015db35e884d47e6a21f6d90a87d560e6ed3e73aeacdf9ac98f7cff28d1e8d1ccba1130b2a569a47a416149353a'
+ '4f869a73813fc37106203aed9b3938ae6f5f53cad7322f71fba44a047c32ab93f8b4fdef65804b1f63f7f26781e2505672b553ee7c9baddb82f01bdc36f870f3'
+ '88f40ff54f8c50f6b07e2620dd5029686e2d6868f908038903384e845c6a81edc346eae73cf1d1777d6709b78723bcc52cccb1f6707e1d17b2162001e8903c0c')
prepare() {
mv -v "${_name}-${pkgver/b/-b}" "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i "${srcdir}/privacy.patch"
+ patch -Np1 -i "${srcdir}/desktop.patch"
+ patch -Np1 -i "${srcdir}/fix_spelling_errors.patch"
+ patch -Np1 -i "${srcdir}/fix_paths.patch"
}
build() {
@@ -26,5 +39,9 @@ build() {
package() {
cd "$pkgname-$pkgver"
make INSTALL_ROOT="${pkgdir}/" install
+ # examples, patches and tools
+ install -d 755 "${pkgdir}/usr/share/${pkgname}/"
+ cp -av {Examples,Patches,Tools} "${pkgdir}/usr/share/${pkgname}/"
+ # docs
install -vDm 644 Readme.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
}
diff --git a/desktop.patch b/desktop.patch
new file mode 100644
index 000000000000..09b8e8415030
--- /dev/null
+++ b/desktop.patch
@@ -0,0 +1,23 @@
+Description: fixed description and binary in .desktop file
+ the binary is called "iannix", not "IanniX" (on case-sensitive filesystems).
+ the description should lack the .desktop extension
+Author: IOhannes m zmölnig
+Forwarded: no
+Last-Update: 2018-02-27
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- iannix.orig/iannix.desktop
++++ iannix/iannix.desktop
+@@ -1,10 +1,10 @@
+ [Desktop Entry]
+ Name=IanniX
+ Comment=Graphical sequencer for digital art
+-Exec=IanniX
++Exec=/usr/bin/iannix
+ Icon=/usr/share/pixmaps/IanniX.png
+ Terminal=false
+ Type=Application
+ X-MultipleArgs=false
+ Categories=Audio;AudioVideoEditing;AudioVideo;Video;Qt;
+-Name[en_US]=IanniX.desktop
++Name[en_US]=IanniX
diff --git a/fix_paths.patch b/fix_paths.patch
new file mode 100644
index 000000000000..52b8b1575fe9
--- /dev/null
+++ b/fix_paths.patch
@@ -0,0 +1,16 @@
+diff -ruN IanniX-0.9.20-b-a/iannixapp.cpp IanniX-0.9.20-b-b/iannixapp.cpp
+--- IanniX-0.9.20-b-a/iannixapp.cpp 2017-10-24 05:17:46.000000000 +0200
++++ IanniX-0.9.20-b-b/iannixapp.cpp 2018-03-25 23:13:41.381359958 +0200
+@@ -114,9 +114,9 @@
+ Application::pathTools = pathApplicationDirM.absolutePath() + "/Resources/Tools";
+ Application::pathPatches = pathApplicationDirM.absolutePath() + "/Resources/Patches";
+ #else
+- Application::pathExamples = Application::pathApplication.absoluteFilePath() + "/Examples";
+- Application::pathTools = Application::pathApplication.absoluteFilePath() + "/Tools";
+- Application::pathPatches = Application::pathApplication.absoluteFilePath() + "/Patches";
++ Application::pathExamples = Application::pathApplication.absoluteFilePath() + "/../share/iannix/Examples";
++ Application::pathTools = Application::pathApplication.absoluteFilePath() + "/../share/iannix/Tools";
++ Application::pathPatches = Application::pathApplication.absoluteFilePath() + "/../share/iannix/Patches";
+ #endif
+
+ qDebug("Paths");
diff --git a/fix_spelling_errors.patch b/fix_spelling_errors.patch
new file mode 100644
index 000000000000..1843d87b2a80
--- /dev/null
+++ b/fix_spelling_errors.patch
@@ -0,0 +1,39 @@
+Description: fix spelling errors
+Author: IOhannes m zmölnig
+Bug: https://github.com/buzzinglight/IanniX/pull/25
+Last-Update: 2017-05-19
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- iannix.orig/gui/uiview.ui
++++ iannix/gui/uiview.ui
+@@ -1367,7 +1367,7 @@
+ <string>Imports SVG file to score</string>
+ </property>
+ <property name="statusTip">
+- <string>SVG files|IanniX can import SVG files (open vectorial format). Be aware that IanniX tries to make the best it can to import data from SVG, but some of SVG features are not compatible with IanniX philosophy.\nFinaly, SVG is based on print or display units whereas IanniX is based on seconds; you may need to rescale the imported data.</string>
++ <string>SVG files|IanniX can import SVG files (open vectorial format). Be aware that IanniX tries to make the best it can to import data from SVG, but some of SVG features are not compatible with IanniX philosophy.\nFinally, SVG is based on print or display units whereas IanniX is based on seconds; you may need to rescale the imported data.</string>
+ </property>
+ <property name="shortcutContext">
+ <enum>Qt::ApplicationShortcut</enum>
+--- iannix.orig/objects/nxcursor.cpp
++++ iannix/objects/nxcursor.cpp
+@@ -163,7 +163,7 @@
+ time = time / curve->getPathLength() * fakeCurveLength + timeStartOffsetReal / curve->getPathLength();
+ }
+
+- //Finaly
++ //Finally
+ nbLoopOld = nbLoop;
+ calculate();
+
+--- iannix.orig/transport/transport.ui
++++ iannix/transport/transport.ui
+@@ -777,7 +777,7 @@
+ <string>Rendering frame rate</string>
+ </property>
+ <property name="statusTip">
+- <string>Rendering frame rate|IannIX refreshes your score at the displayed frame rate.\n You can also force IanniX to a specific framerate by typing a value in this field. 50fps is fluid but it can also be CPU intensive so feel free to decrease this value if needed.\n Finaly, be aware that graphical frame rate doesn't affect messages accuracy or sample rate.</string>
++ <string>Rendering frame rate|IannIX refreshes your score at the displayed frame rate.\n You can also force IanniX to a specific framerate by typing a value in this field. 50fps is fluid but it can also be CPU intensive so feel free to decrease this value if needed.\n Finally, be aware that graphical frame rate doesn't affect messages accuracy or sample rate.</string>
+ </property>
+ <property name="inputMask">
+ <string notr="true">009 fps</string>
diff --git a/privacy.patch b/privacy.patch
new file mode 100644
index 000000000000..520b5494f94c
--- /dev/null
+++ b/privacy.patch
@@ -0,0 +1,15 @@
+Description: prevent checking upstream website for updates
+Author: IOhannes m zmölnig
+Last-Update: 2017-06-06
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- iannix.orig/iannix.cpp
++++ iannix/iannix.cpp
+@@ -51,6 +51,7 @@
+ //Updates
+ forceUpdate = false;
+ forbidUpdate = !projectToLoad.isEmpty();
++ forbidUpdate = true;
+
+ //Default values
+ setCurrentDocument(0);