summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzefr0x2023-09-01 16:51:20 +0300
committerzefr0x2023-09-01 16:51:20 +0300
commit7d2a4fcdb83e01359d869d9512942b2ab6355c2a (patch)
tree14753ac1b4ceb3fa5e2226e346b7ba1aaab4a320
downloadaur-7d2a4fcdb83e01359d869d9512942b2ab6355c2a.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD44
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc77a71918d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ianny-git
+ pkgdesc = Desktop utility periodically informing the user to take breaks
+ pkgver = 0.1.0alpha.1
+ pkgrel = 1
+ url = https://github.com/zefr0x/ianny
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ makedepends = meson
+ depends = libdbus-1.so
+ provides = ianny
+ conflicts = ianny
+ source = ianny-git::git+https://github.com/zefr0x/ianny#branch=main
+ sha512sums = SKIP
+
+pkgname = ianny-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4307e4dcc8d9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+ianny-git
+src
+pkg
+*.tar.gz
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45683ea69bc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: zefr0x < Matrix: "@zer0-x:kde.org" >
+
+pkgname="ianny-git"
+_pkgname=${pkgname%-git}
+pkgver=0.1.0alpha.1
+pkgrel=1
+pkgdesc="Desktop utility periodically informing the user to take breaks"
+arch=("x86_64")
+url="https://github.com/zefr0x/ianny"
+license=("GPL3")
+depends=("libdbus-1.so")
+makedepends=("cargo" "meson")
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+source=("${pkgname}::git+${url}#branch=main")
+sha512sums=("SKIP")
+
+pkgver() {
+ cd "${pkgname}"
+
+ git describe --tags --abbrev=0 --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${pkgname}"
+
+ git reset --hard "$(git describe --tags --abbrev=0 --match 'v*')"
+
+ meson build
+}
+
+build() {
+ cd "${pkgname}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+
+ meson compile -C build
+}
+
+package() {
+ cd "${pkgname}"
+
+ meson install -C build --destdir "${pkgdir}"
+}