summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTristan Rice2020-01-29 20:45:34 -0800
committerTristan Rice2020-01-29 20:45:34 -0800
commitca8cc7b64483b70db0cf265ca18ba96a89424983 (patch)
treeee95f44502ebe276d1688d63f50ce427c0368297
downloadaur-ca8cc7b64483b70db0cf265ca18ba96a89424983.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0be018e9966
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = iasimage-git
+ pkgdesc = iasimage is a utility program for creating Intel Automotive Service (IAS) images, a binary file format understood by bootloaders to load and initialize Operating Systems or Hypervisors.
+ pkgver = 20190410.7799ac7
+ pkgrel = 1
+ url = https://github.com/intel/iasimage
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = custom:MIT
+ makedepends = git
+ depends = python-idna
+ depends = python-wheel
+ depends = python-cryptography
+ provides = iasimage
+ conflicts = iasimage
+ source = iasimage::git+https://github.com/intel/iasimage.git
+ sha1sums = SKIP
+
+pkgname = iasimage-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..542bc01960db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#Maintainer: Tristan Rice <rice at fn dot lc>
+
+_pkgname="iasimage"
+pkgname="${_pkgname}-git"
+pkgver=20190410.7799ac7
+pkgrel=1
+pkgdesc='iasimage is a utility program for creating Intel Automotive Service (IAS) images, a binary file format understood by bootloaders to load and initialize Operating Systems or Hypervisors.'
+url='https://github.com/intel/iasimage'
+arch=('i686' 'x86_64' 'armv7h')
+license=('custom:MIT')
+depends=('python-idna' 'python-wheel' 'python-cryptography')
+makedepends=('git')
+source=("${_pkgname}::git+https://github.com/intel/iasimage.git")
+sha1sums=('SKIP')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver() {
+cd "${srcdir}/${_pkgname}"
+git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+check() {
+cd "${srcdir}/${_pkgname}"
+make check
+}
+
+package() {
+cd "${srcdir}/${_pkgname}"
+install -Dm755 iasimage.py "${pkgdir}/usr/bin/iasimage"
+install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}