aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Alex2017-05-31 10:13:03 +1000
committerBen Alex2017-05-31 10:13:03 +1000
commit07fb6766568355291a11e79a372ee832a1ef5fd0 (patch)
tree1c4df2c8e7dcfb3b9c79c5749172550536e92be1
parentb6db04acbb9509f06da8af47429430cf6c3b8254 (diff)
downloadaur-07fb6766568355291a11e79a372ee832a1ef5fd0.tar.gz
Minimal changes to use Oracle JRE
This fixes the reported bug where launch halts at the "Processing startup parameters" stage. It now appears Oracle JRE is required. Some testing was performed with the java-openjfx package, which allowed launch but no interaction with the resulting application window was available. It is noted the ib-gw script to load IB Gateway appears to work without needing the Oracle JRE, but separating the packages is of limited value given the relatively limited number of expected deployments and the already high maintenance cost of this package.
-rw-r--r--PKGBUILD8
-rwxr-xr-x[-rw-r--r--]ib-gw2
-rwxr-xr-x[-rw-r--r--]ib-tws5
3 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5b2fce47970e..4042cd42eb31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc='Electronic trading platform from discount brokerage firm Interactive Br
arch=('any')
url="http://interactivebrokers.com/"
license=('custom')
-depends=(java-environment bash)
+depends=(jre bash)
makedepends=(imagemagick gzip tar)
source=('LICENSE'
@@ -17,11 +17,11 @@ source=('LICENSE'
'ib-gw.desktop'
'https://download2.interactivebrokers.com/installers/tws/latest-standalone/tws-latest-standalone-linux-x64.sh')
md5sums=('e1cae2de592add7133bb08123e8db1ad'
- 'c407d22dfafdb33ec2fe97eeb5e9f0aa'
+ 'f6475c9ea0bdd03e9dec608983ae1218'
'9205b5eade96d69f8e470cc52c30db4a'
- 'c95eeb41fec3aae6ad5e82703a39060c'
+ '4fde990121cb3b4f0fad029d3c923cbe'
'ffa9fcfb623850e5c9e796040bdbd052'
- '7c755b9d5b6889e2c89fd924b9a18807')
+ 'b5c6bbb526862cfd463304fb1da4dbc9')
build() {
diff --git a/ib-gw b/ib-gw
index d974ee519fbf..4167226ca936 100644..100755
--- a/ib-gw
+++ b/ib-gw
@@ -1,4 +1,4 @@
#!/bin/bash
cd /usr/share/java/ib-tws
-$JAVA_HOME/bin/java -cp \* -Xmx512M -XX:MaxPermSize=128M -Dsun.java2d.noddraw=true ibgateway.GWClient $HOME/.ib-tws
+/usr/lib/jvm/java-8-jre/jre/bin/java -cp \* -Xmx512M -XX:MaxPermSize=128M -Dsun.java2d.noddraw=true ibgateway.GWClient $HOME/.ib-tws
diff --git a/ib-tws b/ib-tws
index a498b88fcc55..0dfc9933d02e 100644..100755
--- a/ib-tws
+++ b/ib-tws
@@ -1,4 +1,5 @@
#!/bin/bash
cd /usr/share/java/ib-tws
-$JAVA_HOME/bin/java -cp \* -Xmx512M -XX:MaxPermSize=128M jclient.LoginFrame $HOME/.ib-tws
-
+/usr/lib/jvm/java-8-jre/jre/bin/java -cp \* \
+ -Xmx768m -Dsun.awt.nopixfmt=true -Dsun.java2d.noddraw=true -Dswing.boldMetal=false -Dsun.locale.formatasdefault=true \
+ jclient.LoginFrame $HOME/.ib-tws