summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Buchanan2017-11-13 20:34:49 -0800
committerJustin Buchanan2017-11-13 20:39:27 -0800
commit6b39299e73ffa68ac3d08e366b566a65cd0a98e4 (patch)
treee7bba4fe2b2fd5b3d42d0e3ec326ff08f763f2ee
downloadaur-6b39299e73ffa68ac3d08e366b566a65cd0a98e4.tar.gz
initial version of ibazel-git package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0866c0e0f1c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ibazel-git
+ pkgdesc = Tool for building Bazel targets when source files change.
+ pkgver = master
+ pkgrel = 1
+ url = https://github.com/bazelbuild/bazel-watcher
+ arch = i686
+ arch = x86_64
+ license = Apache 2.0
+ depends = bazel
+ source = bazel-watcher::git+https://github.com/bazelbuild/bazel-watcher#branch=master
+ sha512sums = SKIP
+
+pkgname = ibazel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..581489888a46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer Justin Buchanan <justbuchanan@gmail.com>
+
+pkgname=ibazel-git
+pkgver=master
+pkgrel=1
+pkgdesc='Tool for building Bazel targets when source files change.'
+arch=('i686' 'x86_64')
+url=https://github.com/bazelbuild/bazel-watcher
+license=('Apache 2.0')
+depends=('bazel')
+source=("bazel-watcher::git+$url#branch=$pkgver")
+sha512sums=('SKIP')
+
+build() {
+ cd bazel-watcher
+ bazel build //ibazel
+}
+
+package() {
+ cd bazel-watcher
+ install -Dm755 bazel-bin/ibazel/ibazel "$pkgdir"/usr/bin/ibazel
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/ibazel/LICENSE
+}