summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2023-07-11 18:41:54 +0300
committerMantas Mikulėnas2023-07-11 18:43:32 +0300
commit07de22bcde73d1de36c397b75b645529de759f47 (patch)
tree5c8a2981feee6c1c9e60631dba0fe27fe2e237bf
parent24f43452c3aa808c596c8abb9e8abffc8952ceba (diff)
downloadaur-07de22bcde73d1de36c397b75b645529de759f47.tar.gz
mst build doesn't work on my system
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47d1eca2c67b..c41db980fc12 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = ibdump
pkgdesc = InfiniBand and RoCE RDMA packet capture tool for Mellanox
pkgver = 6.1.0.r35.ge656df3
- pkgrel = 2
+ pkgrel = 1
url = https://github.com/Mellanox/ibdump
arch = x86_64
license = GPL2
license = custom:BSD
makedepends = git
- makedepends = mstflint
depends = libibverbs
source = git+https://github.com/Mellanox/ibdump#commit=e656df3a89c823fcfebc58961ecd4ce8fa6533d4
source = unbork.diff
diff --git a/PKGBUILD b/PKGBUILD
index 01760a3e13c8..fcadfa0c9220 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
pkgname=ibdump
_commit=e656df3a89c823fcfebc58961ecd4ce8fa6533d4
pkgver=6.1.0.r35.ge656df3
-pkgrel=2
+pkgrel=1
pkgdesc="InfiniBand and RoCE RDMA packet capture tool for Mellanox"
url="https://github.com/Mellanox/ibdump"
license=(GPL2 custom:BSD)
arch=(x86_64)
depends=(libibverbs)
-makedepends=(git mstflint)
+makedepends=(git)
source=("git+https://github.com/Mellanox/ibdump#commit=$_commit"
unbork.diff)
sha256sums=('SKIP'
'1b951beecf20d488e97bdbcc80e414eb1898e2cd994ec579f3a56b52edd55d3c')
+if (( mstflint )); then
+ # Run `makepkg mstflint=1` to enable. I don't, because I have ConnectX-3.
+ # (Might do split-packages with 'ibdump' and 'ibdump-mst' if needed.)
+ makedepends+=(mstflint)
+fi
+
pkgver() {
cd ibdump
git describe --tags | sed 's/^ibdump-//; s/-/.r/; s/[-_]/./g'
@@ -27,10 +33,13 @@ prepare() {
build() {
cd ibdump
- # Build with mstflint (for new ConnectX, but breaks CX3):
- make WITH_MSTFLINT=yes MSTFLINT_INCLUDE_DIR=/usr/include/mstflint
- # Build without mstflint (for ConnectX <= 3):
- # make WITHOUT_FW_TOOLS=yes
+ if (( mstflint )); then
+ # Build with mstflint (for new ConnectX, but breaks CX3):
+ make WITH_MSTFLINT=yes MSTFLINT_INCLUDE_DIR=/usr/include/mstflint
+ else
+ # Build without mstflint (for ConnectX <= 3):
+ make WITHOUT_FW_TOOLS=yes
+ fi
}
package() {