summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2023-07-11 18:23:30 +0300
committerMantas Mikulėnas2023-07-11 18:23:34 +0300
commit533e751e90874ede5225118525e5ef7f238fdea5 (patch)
tree5cebf73aafd99af38ec5c7588688b70a7b98146e
downloadaur-533e751e90874ede5225118525e5ef7f238fdea5.tar.gz
release 6.1.0+
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rw-r--r--sniffer.pcapbin0 -> 232 bytes
-rw-r--r--unbork.diff17
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c41db980fc12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ibdump
+ pkgdesc = InfiniBand and RoCE RDMA packet capture tool for Mellanox
+ pkgver = 6.1.0.r35.ge656df3
+ pkgrel = 1
+ url = https://github.com/Mellanox/ibdump
+ arch = x86_64
+ license = GPL2
+ license = custom:BSD
+ makedepends = git
+ depends = libibverbs
+ source = git+https://github.com/Mellanox/ibdump#commit=e656df3a89c823fcfebc58961ecd4ce8fa6533d4
+ source = unbork.diff
+ sha256sums = SKIP
+ sha256sums = 1b951beecf20d488e97bdbcc80e414eb1898e2cd994ec579f3a56b52edd55d3c
+
+pkgname = ibdump
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..959e8a0b32e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=ibdump
+_commit=e656df3a89c823fcfebc58961ecd4ce8fa6533d4
+pkgver=6.1.0.r35.ge656df3
+pkgrel=1
+pkgdesc="InfiniBand and RoCE RDMA packet capture tool for Mellanox"
+url="https://github.com/Mellanox/ibdump"
+license=(GPL2 custom:BSD)
+arch=(x86_64)
+depends=(libibverbs)
+makedepends=(git)
+source=("git+https://github.com/Mellanox/ibdump#commit=$_commit"
+ unbork.diff)
+sha256sums=('SKIP'
+ '1b951beecf20d488e97bdbcc80e414eb1898e2cd994ec579f3a56b52edd55d3c')
+
+pkgver() {
+ cd ibdump
+ git describe --tags | sed 's/^ibdump-//; s/-/.r/; s/[-_]/./g'
+}
+
+prepare() {
+ cd ibdump
+ patch -Np1 < ../unbork.diff
+}
+
+build() {
+ cd ibdump
+ make WITHOUT_FW_TOOLS=yes
+}
+
+package() {
+ cd ibdump
+ install -D -m 0755 ./ibdump "$pkgdir"/usr/bin/ibdump
+ install -D -m 0644 ./LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/sniffer.pcap b/sniffer.pcap
new file mode 100644
index 000000000000..03a16106914e
--- /dev/null
+++ b/sniffer.pcap
Binary files differ
diff --git a/unbork.diff b/unbork.diff
new file mode 100644
index 000000000000..88355990ee37
--- /dev/null
+++ b/unbork.diff
@@ -0,0 +1,17 @@
+diff --git a/ibdump.c b/ibdump.c
+index a9405b7..500579d 100644
+--- a/ibdump.c
++++ b/ibdump.c
+@@ -998,9 +998,9 @@ int set_sw_sniffer(struct resources *res, int mode, int is_tx, int is_rx)
+ if ((res->dev_rev_id == DI_CIB) || (res->dev_rev_id == DI_CX4) ||
+ (res->dev_rev_id == DI_CX4LX) || (res->dev_rev_id == DI_CX5) ||
+ (res->dev_rev_id == DI_CX6) || (res->dev_rev_id == DI_CX6DX) ||
+- (res->dev_rev_id == DI_CX7) || (res->dev_rev_id != DI_CX8) ||
+- (res->dev_rev_id != DI_BF2) || (res->dev_rev_id != DI_BF2A1) ||
+- (res->dev_rev_id != DI_BF3) || (res->dev_rev_id != DI_BF4))
++ (res->dev_rev_id == DI_CX7) || (res->dev_rev_id == DI_CX8) ||
++ (res->dev_rev_id == DI_BF2) || (res->dev_rev_id == DI_BF2A1) ||
++ (res->dev_rev_id == DI_BF3) || (res->dev_rev_id == DI_BF4))
+ {
+ return fifth_gen_set_sw_sniffer(res, mode);
+ }