summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Jost2018-08-08 16:01:12 +0200
committerThomas Jost2018-08-08 16:01:12 +0200
commitb8cca096b02ba5115addf8039839936d06628898 (patch)
treeb859da398f5ebd5c48c46aaf9ad5212f58e25b24
downloadaur-b8cca096b02ba5115addf8039839936d06628898.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..507eba622b8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Aug 8 13:58:54 UTC 2018
+pkgbase = iblocklist2ipset
+ pkgdesc = Convert P2P lists from IBlocklist.com to IPSet compatile format
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/9seconds/iblocklist2ipset
+ arch = any
+ license = MIT
+ depends = python-docopt
+ depends = python-netaddr
+ depends = python-requests
+ depends = python-six
+ source = https://github.com/9seconds/iblocklist2ipset/archive/0.0.1.tar.gz
+ md5sums = fe0ec2cdd98e1a5c1688478fad08c1a2
+ sha256sums = 931fc1e1fd122831a971f5cd2a0b6278dc3d99e64ef25506ba18626b7e20de7d
+
+pkgname = iblocklist2ipset
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ff4d4c16b15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Thomas Jost <schnouki@schnouki.net>
+pkgname=iblocklist2ipset
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Convert P2P lists from IBlocklist.com to IPSet compatile format"
+arch=(any)
+url="https://github.com/9seconds/iblocklist2ipset"
+license=('MIT')
+depends=('python-docopt' 'python-netaddr' 'python-requests' 'python-six')
+source=("https://github.com/9seconds/iblocklist2ipset/archive/$pkgver.tar.gz")
+md5sums=('fe0ec2cdd98e1a5c1688478fad08c1a2')
+sha256sums=('931fc1e1fd122831a971f5cd2a0b6278dc3d99e64ef25506ba18626b7e20de7d')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ for f in requirements.txt setup.py; do
+ sed -i 's/\([a-z]\{1,\}\)==\([0-9]\{1,\}\)/\1>=\2/g' "$f"
+ done
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" -O2
+}