summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsbiego2019-04-01 23:11:36 +0200
committersbiego2019-04-01 23:11:36 +0200
commitccc35edab03af27999892899fd4e4945d41a1fe3 (patch)
tree3a5ee631aa632ce0d6fe9df4ecfb715a8ecd8587
parent4d4e46a7a9b120aa5a7013dcd849bf0c7c798d28 (diff)
downloadaur-ccc35edab03af27999892899fd4e4945d41a1fe3.tar.gz
added content
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD41
-rw-r--r--iblu.install24
3 files changed, 53 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4834076f505..e946a0991112 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
-pkgbase = pkgbase
- pkgdesc = Refreshed new Adwaita theme with creamy colors and minor changes.
- pkgver = 0.1
+pkgbase = iblu
+ pkgdesc = Intel Black Light Utility, written in python, allows you to control the screen brightness (iX processors family), via command line interface.
+ pkgver = 0.9
pkgrel = 1
- url = https://github.com/murat-cileli/adwaita-creamy
+ url = https://git.eigenlab.org/sbiego/iblu
+ install = iblu.install
+ arch = i686
arch = x86_64
- license = MIT
- provides = adwaita-creamy
- source = git+https://github.com/murat-cileli/adwaita-creamy.git
- sha256sums = SKIP
+ arch = aarch64
+ license = GPLv3
+ depends = python
+ provides = iblu
+ source = https://git.eigenlab.org/sbiego/iblu/-/archive/v0.9/iblu-v0.9.tar.gz
+ sha256sums = 604aec80a03d72c34b5ca807fd2715fedbe73651010d489f43a4c5881ff87d52
-pkgname = adwaita-creamy
+pkgname = iblu
diff --git a/PKGBUILD b/PKGBUILD
index a6bbc4ba865b..81424184cc62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,19 @@
-# Maintainer: Murat Çileli <murat.cileli@gmail.com>
-
-pkgbase="pkgbase"
-pkgname="adwaita-creamy"
-pkgver="0.1"
-pkgrel="1"
-pkgdesc="Refreshed new Adwaita theme with creamy colors and minor changes. "
-arch=("x86_64")
-license=("MIT")
-url="https://github.com/murat-cileli/adwaita-creamy"
-makedepends=()
-provides=("adwaita-creamy")
-
-source=("git+https://github.com/murat-cileli/adwaita-creamy.git")
-sha256sums=("SKIP")
-
-build() {
- cd "${pkgname}"
- mkdir -p ~/.themes/adwaita-creamy
- cp gtk-2.0 ~/.themes/adwaita-creamy/ -R
- cp gtk-3.0 ~/.themes/adwaita-creamy/ -R
- cp index.theme ~/.themes/adwaita-creamy/
-}
+# Maintainer: diesys <code@flowin.space>
+pkgname=iblu
+pkgver=0.9
+pkgrel=1
+pkgdesc="Intel Black Light Utility, written in python, allows you to control the screen brightness (iX processors family), via command line interface."
+arch=('any')
+url="https://git.eigenlab.org/sbiego/iblu"
+license=('GPLv3')
+depends=('python')
+provides=($pkgname)
+install=$pkgname.install
+source=(https://git.eigenlab.org/sbiego/iblu/-/archive/v$pkgver/iblu-v$pkgver.tar.gz)
+sha256sums=('604aec80a03d72c34b5ca807fd2715fedbe73651010d489f43a4c5881ff87d52')
package() {
- echo "Package"
+ ## copia file
+ cd "$srcdir/$pkgname"
+ install -D $pkgname.py $pkgdir/usr/bin/$pkgname
}
-
diff --git a/iblu.install b/iblu.install
new file mode 100644
index 000000000000..8f3ac0ee3b0e
--- /dev/null
+++ b/iblu.install
@@ -0,0 +1,24 @@
+post_install() {
+
+ ### UNCOMMENT the following lines to CREATE and ENABLE the systemd unit
+ # it's MANDATORY execute those to run iblu
+
+ # iblu UNIT > /usr/lib/systemd/system/iblu.service; #creates the systemd unit file
+ # systemctl start iblu.service; #enabling the service
+ # systemctl enable iblu.service; #enabling the service
+
+
+ echo -e "\n\tIBLU is ALMOST INSTALLED! \n\tPlease run the following commands:\n\n\t # iblu UNIT > /usr/lib/systemd/system/iblu.service \t#creates the systemd unit file \n\t # systemctl start iblu.service \t\t\t\t#starting the service\n\t # systemctl enable iblu.service \t\t\t\t#enabling the service\n"
+}
+
+
+
+
+
+################################################################################################
+# read -p "Do you want to do it now (y/n)?" choice
+# case "$choice" in
+# y|Y ) iblu UNIT > /usr/lib/systemd/system/iblu.service; systemctl start iblu.service; systemctl enable iblu.service;;
+# n|N ) echo "You can always to it running the following commands:\n\n\t # iblu UNIT > /usr/lib/systemd/system/iblu.service \t#creates the systemd unit file \n\t # systemctl start iblu.service \t\t\t\t#starting the service\n\t # systemctl enable iblu.service \t\t\t\t#enabling the service\n";;
+# * ) echo "invalid";;
+# esac \ No newline at end of file