summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsbiego2019-04-01 00:59:02 +0200
committersbiego2019-04-01 00:59:02 +0200
commitaa1f0f8abdbca1c531617bde9ea289c9ac06dd44 (patch)
tree9670f0099530832d686bc634811d2a882f3373b1
parent4d4e46a7a9b120aa5a7013dcd849bf0c7c798d28 (diff)
downloadaur-aa1f0f8abdbca1c531617bde9ea289c9ac06dd44.tar.gz
commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD51
-rw-r--r--iblu.install3
3 files changed, 44 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4834076f505..195715ad2178 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
-pkgbase = pkgbase
- pkgdesc = Refreshed new Adwaita theme with creamy colors and minor changes.
- pkgver = 0.1
+pkgbase = iblu-git
+ pkgdesc = Intel Black Light Utility, written in python, allows you to control the screen brightness (iX processors family), via command line interface.
+ pkgver = 0.8
pkgrel = 1
- url = https://github.com/murat-cileli/adwaita-creamy
+ url = https://git.eigenlab.org/sbiego/iblu
+ arch = i686
arch = x86_64
- license = MIT
- provides = adwaita-creamy
- source = git+https://github.com/murat-cileli/adwaita-creamy.git
- sha256sums = SKIP
+ arch = aarch64
+ license = GPLv3
+ makedepends = git
+ depends = python
+ provides = iblu
+ conflicts = iblu
+ source = git+https://git.eigenlab.org/sbiego/iblu
+ md5sums = SKIP
-pkgname = adwaita-creamy
+pkgname = iblu-git
diff --git a/PKGBUILD b/PKGBUILD
index a6bbc4ba865b..93c9a2250bbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
-# Maintainer: Murat Çileli <murat.cileli@gmail.com>
+# Maintainer: diesys <code@flowin.space>
+pkgname=iblu-git
+pkgver=0.8
+pkgrel=1
+pkgdesc="Intel Black Light Utility, written in python, allows you to control the screen brightness (iX processors family), via command line interface."
+arch=('i686' 'x86_64' 'aarch64')
+url="https://git.eigenlab.org/sbiego/iblu"
+license=('GPLv3')
+groups=()
+depends=('python')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://git.eigenlab.org/sbiego/iblu')
+noextract=()
+md5sums=('SKIP')
-pkgbase="pkgbase"
-pkgname="adwaita-creamy"
-pkgver="0.1"
-pkgrel="1"
-pkgdesc="Refreshed new Adwaita theme with creamy colors and minor changes. "
-arch=("x86_64")
-license=("MIT")
-url="https://github.com/murat-cileli/adwaita-creamy"
-makedepends=()
-provides=("adwaita-creamy")
-
-source=("git+https://github.com/murat-cileli/adwaita-creamy.git")
-sha256sums=("SKIP")
-
-build() {
- cd "${pkgname}"
- mkdir -p ~/.themes/adwaita-creamy
- cp gtk-2.0 ~/.themes/adwaita-creamy/ -R
- cp gtk-3.0 ~/.themes/adwaita-creamy/ -R
- cp index.theme ~/.themes/adwaita-creamy/
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- echo "Package"
-}
-
+ ## copia file
+ cd "$srcdir/${pkgname%-git}"
+ install -D ${pkgname%-git} $pkgdir/usr/bin/${pkgname%-git}
+} \ No newline at end of file
diff --git a/iblu.install b/iblu.install
new file mode 100644
index 000000000000..98a00b1ebbe7
--- /dev/null
+++ b/iblu.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "\nIBLU is ALMOST INSTALLED! \nPlease run the following commands:\n\n\t # iblu --install > /usr/lib/systemd/system/iblu.service \t#creates the systemd unit file \n\t # systemctl enable iblu.service \t\t\t\t#enabling the service\n"
+}