summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Harvey2015-07-17 21:44:35 +0000
committerJames Harvey2015-07-17 21:44:35 +0000
commit1f202f7d496f64052e91a8a35ba5cdb964aa0734 (patch)
tree800f513430567e8ef6b5411ac829abc1eee41aeb
downloadaur-1f202f7d496f64052e91a8a35ba5cdb964aa0734.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03d972986402
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ibsim
+ pkgdesc = OpenFabrics Alliance InfiniBand simulator utilities
+ pkgver = 0.6
+ pkgrel = 1
+ url = https://www.openfabrics.org/index.php/overview.html
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ license = custom:"Open Fabrics Alliance BSD"
+ depends = libibmad
+ depends = bash
+ source = https://www.openfabrics.org/downloads/management/ibsim-0.6.tar.gz
+ md5sums = d08e196d980e7c88066b3e5e25bf5432
+
+pkgname = ibsim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2b778d47da6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: James Harvey <jamespharvey20@gmail.com>
+# * No namcap warnings or errors
+
+pkgname=ibsim
+pkgver=0.6
+pkgrel=1
+pkgdesc='OpenFabrics Alliance InfiniBand simulator utilities'
+# Simulates InfiniBand fabric, which can be used by any libibumad based application
+# Works locally via unix sockets or remotely via inet sockets
+arch=('x86_64' 'i686')
+url=('https://www.openfabrics.org/index.php/overview.html')
+license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
+depends=('libibmad' 'bash')
+source=("https://www.openfabrics.org/downloads/management/${pkgname}-${pkgver}.tar.gz")
+md5sums=('d08e196d980e7c88066b3e5e25bf5432')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # ibsim doesn't use configure, just make
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make libpath=/usr/lib DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 README "${pkgdir}/usr/share/licenses/${pkgname}/README"
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -r net-examples scripts "${pkgdir}/usr/share/doc/${pkgname}"
+}