summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryanganto2015-12-22 00:03:07 +0800
committeryanganto2015-12-22 00:03:07 +0800
commit62e9e062a24b2bfd04e39656bf6e58b090635203 (patch)
tree1f5e1fdb65e19e46e6d6a9168716758e5120674c
downloadaur-62e9e062a24b2bfd04e39656bf6e58b090635203.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5274548cbfcb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Dec 21 16:02:31 UTC 2015
+pkgbase = ibus-array
+ pkgdesc = A full function array ibus input method
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://code.google.com/p/ibus-array/
+ arch = any
+ license = GPL2
+ makedepends = base-devel
+ depends = ibus
+ noextract = ibus-array-0.1.0.tgz
+ source = http://ibus-array.googlecode.com/svn/tarballs/ibus-array-0.1.0.tgz
+ md5sums = e4578c1b7ebf20cc19010b53b42ef20c
+
+pkgname = ibus-array
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92fa798e9db8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Po-An,Yang(Antonio) <yanganto@gmail.com>
+pkgname=ibus-array
+pkgver=0.1.0
+pkgrel=1
+epoch=
+pkgdesc="A full function array ibus input method"
+arch=('any')
+url="https://code.google.com/p/ibus-array/"
+license=('GPL2')
+groups=()
+depends=('ibus')
+makedepends=('base-devel')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://ibus-array.googlecode.com/svn/tarballs/ibus-array-0.1.0.tgz")
+noextract=("ibus-array-0.1.0.tgz")
+md5sums=("e4578c1b7ebf20cc19010b53b42ef20c")
+validpgpkeys=()
+
+prepare() {
+ tar -zxvf ibus-array-0.1.0.tgz
+ $srcdir/autogen.sh
+}
+build() {
+ ./configure --prefix=/usr \
+ --without-PACKAGE \
+ --libexecdir=/usr/lib/ibus
+ make
+}
+check(){
+ echo no check with this build
+}
+package() {
+ make DESTDIR="${pkgdir}" install
+}
+