summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLolix2019-06-25 00:23:58 +0200
committerLolix2019-06-25 00:23:58 +0200
commite785b50f4adefce0940f20f3a3c849d49bead46f (patch)
treeedb7a0773ceda199d315b5571bfe0bb7b9428e47
parent21e1f1e0e37dc42fa0a0686c4fc7047d00dfea1f (diff)
downloadaur-e785b50f4adefce0940f20f3a3c849d49bead46f.tar.gz
Revision
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD57
-rwxr-xr-xibus-avro-git.install11
3 files changed, 33 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77d69eaa75bf..38a69f2e45bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
-# Generated by mksrcinfo v8
-# Sun Sep 25 10:45:50 UTC 2016
pkgbase = ibus-avro-git
pkgdesc = Avro Phonetic Bangla typing for Linux
- pkgver = 20150925
+ pkgver = 1.0.r8.gfe50959
pkgrel = 1
+ epoch = 1
url = http://linux.omicronlab.com
- install = ibus-avro-git.install
- arch = x86_64
- arch = i686
+ arch = any
license = MPL
+ makedepends = git
makedepends = autoconf
makedepends = automake
depends = ibus
depends = gjs
+ source = git+https://github.com/sarim/ibus-avro
+ sha256sums = SKIP
pkgname = ibus-avro-git
diff --git a/PKGBUILD b/PKGBUILD
index c3799df84c3a..b557d1fccefb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,40 @@
-# Maintainer: Mahmud Ridwan <m[at]hjr265[dot]me>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Mahmud Ridwan <m[at]hjr265[dot]me>
+
pkgname=ibus-avro-git
-pkgver=20150925
+epoch=1
+pkgver=1.0.r8.gfe50959
pkgrel=1
pkgdesc="Avro Phonetic Bangla typing for Linux"
url="http://linux.omicronlab.com"
-arch=('x86_64' 'i686')
-license=('MPL')
-depends=('ibus' 'gjs')
-makedepends=('autoconf' 'automake')
-install=$pkgname.install
-
-build() {
- cd "$srcdir"
-
- if [ -e $pkgname ]; then
- cd $pkgname
- git pull
- git checkout develop
- else
- git clone -b develop git://github.com/sarim/ibus-avro.git $pkgname
- cd $pkgname
- fi
-
- aclocal || return 1
- autoconf || return 1
+arch=(any)
+license=(MPL)
+depends=(ibus gjs)
+makedepends=(git autoconf automake)
+source=("git+https://github.com/sarim/ibus-avro")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+prepare() {
+ cd ${pkgname%-git}
+ aclocal
+ autoconf
automake --add-missing
- ./configure --prefix=/usr
+}
- make || return 1
+build() {
+ cd ${pkgname%-git}
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$srcdir/$pkgname"
-
+ cd ${pkgname%-git}
make DESTDIR="$pkgdir" installdeb
- install -Dm644 MPL-1.1.txt "$pkgdir/usr/share/licenses/$pkgname/COPYING"
-
- sed -i 's|<layout>bn</layout>|<layout>us</layout>|' "$pkgdir/usr/share/ibus/component/ibus-avro.xml"
-
rmdir "$pkgdir/usr/libexec"
+ sed -i 's|<layout>bn</layout>|<layout>us</layout>|' "$pkgdir/usr/share/ibus/component/ibus-avro.xml"
}
diff --git a/ibus-avro-git.install b/ibus-avro-git.install
deleted file mode 100755
index c19349f7230c..000000000000
--- a/ibus-avro-git.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- glib-compile-schemas /usr/share/glib-2.0/schemas
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}