summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTran Cong2019-09-04 16:17:54 +0700
committerTran Cong2019-09-04 16:17:54 +0700
commit3d40c9bbe74d9c2528d46fcbf52392b52b5fe3b5 (patch)
tree0a6bae560c3857f95748333307625ae3fcdd6e92
downloadaur-3d40c9bbe74d9c2528d46fcbf52392b52b5fe3b5.tar.gz
ibus-bamboo-git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD50
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bb3cb80a975
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ibus-bamboo-git
+ pkgdesc = A Vietnamese IME for IBus
+ pkgver = 0.5.5
+ pkgrel = 1
+ url = https://github.com/BambooEngine/ibus-bamboo
+ arch = any
+ license = GPL3
+ makedepends = go
+ makedepends = libx11
+ makedepends = libxtst
+ depends = ibus
+ conflicts = ibus-bamboo
+ options = !strip
+ source = ibus-bamboo-git::git+https://github.com/BambooEngine/ibus-bamboo.git
+ md5sums = SKIP
+
+pkgname = ibus-bamboo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9224bda7e53f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+#
+# Bamboo - A Vietnamese Input method editor
+# Copyright (C) 2018 Luong Thanh Lam <ltlam93@gmail.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+# Maintainer: Luong Thanh Lam <ltlam93@gmail.com>
+# Contributor: Tran Van Cong
+
+pkgname=ibus-bamboo-git
+pkgver=0.5.5
+pkgrel=1
+pkgdesc='A Vietnamese IME for IBus'
+arch=(any)
+license=(GPL3)
+url="https://github.com/BambooEngine/ibus-bamboo"
+depends=('ibus')
+makedepends=('go' 'libx11' 'libxtst')
+source=("$pkgname"::git+'https://github.com/BambooEngine/ibus-bamboo.git')
+md5sums=('SKIP')
+options=('!strip')
+conflicts=(ibus-bamboo)
+
+prerare () {
+ git clone https://github.com/BambooEngine/ibus-bamboo.git
+}
+
+build() {
+ cd "$pkgname"
+
+ make
+}
+
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir/" install
+}