summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMinh Ngo2022-07-02 05:32:22 +0700
committerMinh Ngo2022-07-02 05:32:22 +0700
commitab7b250ca9ef046298fa2fee8e9676e26d4e13ba (patch)
tree961b12dc05622e08350a18f196c5d553c3ee6d73
parent6a00ad854e2318a5d3ba6beea91c32d5869ab54d (diff)
downloadaur-ab7b250ca9ef046298fa2fee8e9676e26d4e13ba.tar.gz
refactoring
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c739640e8786..bbb6ce437154 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ibus-bamboo-git
pkgdesc = A Vietnamese IME for IBus
- pkgver = 0.6.5
+ pkgver = 0.8.1.RC4.g3380c09
pkgrel = 1
url = https://github.com/BambooEngine/ibus-bamboo
arch = any
@@ -11,8 +11,7 @@ pkgbase = ibus-bamboo-git
depends = ibus
conflicts = ibus-bamboo
options = !strip
- source = ibus-bamboo-git::git+https://github.com/BambooEngine/ibus-bamboo.git
+ source = ibus-bamboo-git::git+https://github.com/BambooEngine/ibus-bamboo
md5sums = SKIP
pkgname = ibus-bamboo-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 44ac5708badc..1e8abe176b35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,11 +15,11 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# Maintainer: Luong Thanh Lam <ltlam93@gmail.com>
-# Contributor: Tran Cong <nopain2110@gmail.com>
+# Author: Luong Thanh Lam <ltlam93@gmail.com>
+# Maintainer: toitenminh <iam.minhnc@outlook.com>
pkgname=ibus-bamboo-git
-pkgver=0.6.5
+pkgver=0.8.1.RC4.g3380c09
pkgrel=1
pkgdesc='A Vietnamese IME for IBus'
arch=(any)
@@ -27,24 +27,22 @@ license=(GPL3)
url="https://github.com/BambooEngine/ibus-bamboo"
depends=('ibus')
makedepends=('go' 'libx11' 'libxtst')
-source=("$pkgname"::git+'https://github.com/BambooEngine/ibus-bamboo.git')
-md5sums=('SKIP')
-options=('!strip')
conflicts=(ibus-bamboo)
+options=('!strip')
+source=("$pkgname"::git+$url)
+md5sums=('SKIP')
-prerare () {
- git clone https://github.com/BambooEngine/ibus-bamboo.git
+pkgver() {
+ cd "$pkgname"
+ git describe --tags | cut -d '-' --fields=1,2,4 | sed 's#v##;s#-#.#g'
}
build() {
- cd "$pkgname"
-
- make
+ cd "$pkgname"
+ make build
}
-
package() {
- cd "$pkgname"
-
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
}