aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhai96_2020-03-19 09:41:14 +0700
committerkhai96_2020-03-19 09:41:14 +0700
commitf432e45a61f3e46b1138c3790f7151339fedf521 (patch)
tree1677f972edbe7177d9e334e217c90b03b93aabbf
downloadaur-f432e45a61f3e46b1138c3790f7151339fedf521.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--LICENSE.md21
-rw-r--r--PKGBUILD22
-rw-r--r--ibus.service14
5 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdd435a5b394
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ibus-daemon
+ pkgdesc = SystemD user service for IBus
+ pkgver = 0.0.0
+ pkgrel = 0
+ url = https://github.com/KSXGitHub/ibus-daemon.pkgbuild.git
+ arch = any
+ license = MIT
+ makedepends = pkgconf
+ depends = systemd
+ depends = ibus
+ source = ibus.service
+ source = LICENSE.md
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = ibus-daemon
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f07e7ad535bd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.service
+!*.md
diff --git a/LICENSE.md b/LICENSE.md
new file mode 100644
index 000000000000..74e2787c5da8
--- /dev/null
+++ b/LICENSE.md
@@ -0,0 +1,21 @@
+# The MIT License
+
+Copyright © 2020 Hoàng Văn Khải
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..943926dfe8d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Hoàng Văn Khải <hvksmr1996@gmail.com>
+
+pkgname=ibus-daemon
+pkgver=0.0.0
+pkgrel=0
+pkgdesc='SystemD user service for IBus'
+arch=(any)
+license=(MIT)
+url='https://github.com/KSXGitHub/ibus-daemon.pkgbuild.git'
+depends=(systemd ibus)
+makedepends=(pkgconf)
+source=(
+ ibus.service
+ LICENSE.md
+)
+sha512sums=(SKIP SKIP)
+
+package() {
+ cd "$srcdir"
+ install -Dm644 ibus.service "$pkgdir"/"$(pkg-config systemd --variable=systemduserunitdir)"/ibus.service
+ install -Dm644 LICENSE.md "$pkgdir"/usr/share/licenses/ibus-deamon/LICENSE.md
+}
diff --git a/ibus.service b/ibus.service
new file mode 100644
index 000000000000..ae5de2658fce
--- /dev/null
+++ b/ibus.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Intelligent Input Bus
+Documentation=man:ibus-daemon(1)
+Conflicts=fcitx.service
+
+[Service]
+ExecStart=/usr/bin/ibus-daemon --replace --xim
+ExecReload=/usr/bin/ibus restart
+ExecStop=/usr/bin/ibus exit
+Environment=GTK_IM_MODULE=ibus QT_IM_MODULE=ibus XMODIFIERS="@im=ibus"
+
+[Install]
+Alias=input-method.service
+WantedBy=default.target