summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2020-03-16 01:30:34 +0100
committerBalló György2020-03-16 01:30:34 +0100
commitf72e73479a36f0fbea6f6919ee376fc1f6e6551e (patch)
treeef1d1243c8e179c85daa222343d4be0385c10efe
downloadaur-f72e73479a36f0fbea6f6919ee376fc1f6e6551e.tar.gz
Move from [community]
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cdfbc4aee2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ibus-googlepinyin
+ pkgdesc = IBus Wrapper for libgooglepinyin
+ pkgver = 0.1.2
+ pkgrel = 7
+ url = https://code.google.com/archive/p/libgooglepinyin/
+ arch = any
+ license = APACHE
+ makedepends = cmake
+ depends = libgooglepinyin
+ depends = ibus
+ depends = iso-codes
+ depends = pygtk
+ optdepends = opencc: for simplified chinese translation to tranditional chinese
+ source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/libgooglepinyin/ibus-googlepinyin-0.1.2.tar.bz2
+ sha512sums = 0180bd93bed03ef38e283a589fcab3074f0d9197c41e1411d015de8e30ce6cbd72c6765142a42b55227fccc111cc579830b1ad9f4c282f7ac856dd66f58293e7
+
+pkgname = ibus-googlepinyin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d89d53fda288
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Author: Jiahua Huang <jhuangjiahua@gmail.com>
+# Contributor: Yangtse <yangtsesu@gmail.com>
+
+pkgname=ibus-googlepinyin
+pkgver=0.1.2
+pkgrel=7
+pkgdesc="IBus Wrapper for libgooglepinyin"
+arch=('any')
+url="https://code.google.com/archive/p/libgooglepinyin/"
+license=('APACHE')
+optdepends=('opencc: for simplified chinese translation to tranditional chinese')
+depends=('libgooglepinyin' 'ibus' 'iso-codes' 'pygtk')
+makedepends=('cmake')
+source=("https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/libgooglepinyin/${pkgname}-${pkgver}.tar.bz2")
+sha512sums=('0180bd93bed03ef38e283a589fcab3074f0d9197c41e1411d015de8e30ce6cbd72c6765142a42b55227fccc111cc579830b1ad9f4c282f7ac856dd66f58293e7')
+
+prepare() {
+ sed -e 's/zhs2zht.ini/s2t.json/' -i $pkgname/libopencc.py
+ find $pkgname -type f -name '*.py' -exec sed -i 's|/usr/bin/python|/usr/bin/python2|g' {} \;
+
+ rm -rf build
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ../$pkgname
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}