summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkjwon152018-06-13 05:53:29 +0900
committerkjwon152018-06-13 06:03:00 +0900
commitfe2296bf65151e2039e558baf8338f016125208e (patch)
treeb8d73f3d9776ae75fbd3c25b2a53d7410cb6215c
downloadaur-fe2296bf65151e2039e558baf8338f016125208e.tar.gz
First commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD80
2 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebca1b53ac45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ibus-hangul-3beol
+ pkgdesc = ibus-hangul from createsc/3beol PPA
+ pkgver = 1.5.0+git20161231_2.2~bionic0527~3beol
+ pkgrel = 1
+ url = https://launchpad.net/~createsc/3beol
+ arch = x86_64
+ license = unknown
+ makedepends = intltool
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = libhangul
+ makedepends = gnome-common
+ depends = libhangul
+ provides = ibus-hangul
+ conflicts = ibus-hangul
+ source = http://ppa.launchpad.net/createsc/3beol/ubuntu/pool/main/i/ibus-hangul/ibus-hangul_1.5.0+git20161231-2.2~bionic0527~3beol.tar.xz
+ sha256sums = 0e6ccc4f9412f97139ae655ff274e010a8eddd8a4864bc1816f774454ef7f068
+
+pkgname = ibus-hangul-3beol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f02b96e9213f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Maintainer: Jeong Arm <kjwonmail@gmail.com>
+pkgname=ibus-hangul-3beol
+_pkgname=ibus-hangul
+pkgrel=1
+pkgdesc="ibus-hangul from createsc/3beol PPA"
+arch=('x86_64')
+url="https://launchpad.net/~createsc/3beol"
+license=('unknown')
+groups=()
+depends=('libhangul')
+makedepends=('intltool' 'automake' 'autoconf' 'libhangul' 'gnome-common')
+provides=('ibus-hangul')
+conflicts=('ibus-hangul')
+replaces=()
+backup=()
+options=()
+install=
+noextract=()
+
+# XXX Disable this because new lines are joined into space
+# INFO="$(
+# curl -qs http://ppa.launchpad.net/createsc/3beol/ubuntu/dists/bionic/main/source/Sources.gz |\
+# gunzip |\
+# awk -v RS= '{ if ($2 == "ibus-hangul") { print $0 } }'
+# )"
+
+
+source_basedir=$(
+ curl -qs http://ppa.launchpad.net/createsc/3beol/ubuntu/dists/bionic/main/source/Sources.gz |\
+ gunzip |\
+ awk -v RS= '{ if ($2 == "ibus-hangul") { print $0 } }' |\
+ grep -e '^Directory' |\
+ awk '{print $2}'
+ )
+
+source_info=($(
+ curl -qs http://ppa.launchpad.net/createsc/3beol/ubuntu/dists/bionic/main/source/Sources.gz |\
+ gunzip |\
+ awk -v RS= '{ if ($2 == "ibus-hangul") { print $0 } }' |\
+ sed -ne '/^ [0-9a-f]\{64\} [0-9]\+ .*/p' |\
+ grep tar.xz
+ ))
+
+sha256sums=(
+ ${source_info[0]}
+ )
+
+source_url="http://ppa.launchpad.net/createsc/3beol/ubuntu/${source_basedir}/${source_info[2]}"
+
+source=("$source_url")
+
+pkgver=$(
+ curl -qs http://ppa.launchpad.net/createsc/3beol/ubuntu/dists/bionic/main/source/Sources.gz |\
+ gunzip |\
+ awk -v RS= '{ if ($2 == "ibus-hangul") { print $0 } }' |\
+ grep -e '^Version' | awk '{print $2}' |\
+ tr '-' '_'
+ )
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ # touch config.rpath
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$_pkgname"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}