summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVitrum2018-06-15 03:25:56 +0300
committerVitrum2018-06-15 03:25:56 +0300
commit71f53397647a5c92301f1795725a28a19c949f83 (patch)
tree8a3775232cf3d1a869610aaa8ff025bfc2768ec5
parenta83ded96b320183691f5d5a6d2befd406dac9a94 (diff)
downloadaur-71f53397647a5c92301f1795725a28a19c949f83.tar.gz
v10.99.0.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD60
2 files changed, 32 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 553974d9e2bf..e7a655f836cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = ibus-kmfl
- pkgdesc = Keyboard Mapping for Linux (KMFL) input method for IBus
- pkgver = 1.0.8
+ pkgdesc = Keyman input method: ibus engine
+ pkgver = 10.99.0.2
pkgrel = 1
- url = http://kmfl.sourceforge.net/
+ url = https://keyman.com/
arch = i686
arch = x86_64
- license = GPL
- depends = kmflcomp
+ license = MIT
+ depends = ibus
depends = libkmfl
- depends = libibus
- source = https://sourceforge.net/projects/kmfl/files/kmfl/ibus-kmfl/ibus-kmfl-1.0.8.tar.gz
- md5sums = af2357d253b6db9f5d8e9a15d6af6f93
+ source = ibus-kmfl-10.99.0.2.tar.gz::https://github.com/keymanapp/keyman/archive/linux-release-alpha-10.99.0.2.tar.gz
+ md5sums = cd4b8bbe0b528d68c28da4fa6dd90c43
pkgname = ibus-kmfl
diff --git a/PKGBUILD b/PKGBUILD
index 309ddac1ad0f..eeae773ce427 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,46 +2,36 @@
# Maintainer 2018-now : Vitrum <wqdxosty1yhj at bk dot ru>
pkgname=ibus-kmfl
-pkgver=1.0.8
+pkgver=10.99.0.2
pkgrel=1
-pkgdesc="Keyboard Mapping for Linux (KMFL) input method for IBus"
+pkgdesc="Keyman input method: ibus engine"
arch=('i686' 'x86_64')
-url="http://kmfl.sourceforge.net/"
-license=('GPL')
-source=("https://sourceforge.net/projects/kmfl/files/kmfl/ibus-kmfl/ibus-kmfl-$pkgver.tar.gz")
-depends=('kmflcomp' 'libkmfl' 'libibus')
-noextract=()
-options=()
-md5sums=('af2357d253b6db9f5d8e9a15d6af6f93')
+url="https://keyman.com/"
+license=('MIT')
+depends=('ibus' 'libkmfl')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/keymanapp/keyman/archive/linux-release-alpha-$pkgver.tar.gz")
+md5sums=('cd4b8bbe0b528d68c28da4fa6dd90c43')
-build() {
- LDFLAGS="${LDFLAGS} -lX11"
- cd "$pkgname-$pkgver"
- ./configure --prefix=/usr
- make
+prepare() {
+ basedir="$srcdir/keyman-linux-release-alpha-$pkgver/linux"
+ cd "$basedir/$pkgname"
+ sed -i 's/${libexecdir}/\/usr\/lib\/ibus/g' src/kmfl.xml.in.in
}
-package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+build() {
+ basedir="$srcdir/keyman-linux-release-alpha-$pkgver/linux"
+ cd "$basedir/$pkgname"
+ autoreconf
+ ./configure \
+ CPPFLAGS="-I/usr/include" LDFLAGS="-L/usr/lib" \
+ --prefix=$pkgdir/usr \
+ --libexecdir=$pkgdir/usr/lib/ibus \
+ --datadir=$pkgdir/usr/share
+ make
}
-post_install() {
- echo '-----------------------------------------------------------------------------'
- echo 'INFORMATION: newly installed ibus-kmfl engine does not contain keyboard'
- echo 'layouts which can be obtained from the web-sites:'
- echo ''
- echo '* http://tavultesoft.com/keyman/downloads/keyboards/'
- echo '* https://github.com/keymanapp/keyboards'
- echo ''
- echo 'Uncompiled Keyman-style keyboard files (*.kmn) should be copied into the'
- echo "user's directory ~/.kmfl/ or system-wide /usr/share/kmfl/."
- echo ''
- echo 'After restarting ibus-deamon new layouts will be available in the'
- echo 'subcategory "Other". More information about the file format and layout'
- echo 'description language see on the web-site:'
- echo ''
- echo '* https://help.keyman.com/developer/'
- echo '-----------------------------------------------------------------------------'
+package() {
+ basedir="$srcdir/keyman-linux-release-alpha-$pkgver/linux"
+ cd "$basedir/$pkgname"
+ make install
}
-