summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustbrowsing2015-07-08 00:17:11 -0700
committerjustbrowsing2015-07-08 00:17:11 -0700
commit432994584ceb55640e95ba767ec6a8bf67d15f3f (patch)
tree1d1b0f50ef5f286d3121205074ef9aed1714b8d7
downloadaur-432994584ceb55640e95ba767ec6a8bf67d15f3f.tar.gz
Imported to AUR4
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD46
-rw-r--r--ibus.install20
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a040208dca4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ibus-lite
+ pkgdesc = ibus without python3
+ pkgver = 1.5.7
+ pkgrel = 6
+ url = http://ibus.googlecode.com
+ install = ibus.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = intltool
+ makedepends = gnome-common
+ makedepends = gconf
+ depends = libibus
+ depends = dconf
+ depends = gtk2
+ depends = libnotify
+ depends = iso-codes
+ optdepends = vala: build vala bindings
+ provides = ibus=1.5.7
+ conflicts = ibus
+ replaces = ibus
+ options = !emptydirs
+ source = https://github.com/ibus/ibus/archive/1.5.7.tar.gz
+ md5sums = 98f57dbfca36b002b7b4df291f2f04cf
+
+pkgname = ibus-lite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4f80bb093b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: justbrowsing <developer4linux+aur@gmail.com>
+# Contributer: Felix Yan <felixonmars@gmail.com>
+
+pkgname=ibus-lite
+_pkgname=ibus
+pkgver=1.5.7
+pkgrel=6
+pkgdesc="ibus without python3"
+arch=('i686' 'x86_64')
+url="http://ibus.googlecode.com"
+license=('LGPL')
+depends=('libibus' 'dconf' 'gtk2' 'libnotify' 'iso-codes')
+makedepends=('intltool' 'gnome-common' 'gconf')
+optdepends=('vala: build vala bindings')
+provides=('ibus=1.5.7')
+conflicts=('ibus')
+replaces=('ibus')
+options=('!emptydirs')
+install=ibus.install
+source="https://github.com/ibus/ibus/archive/1.5.7.tar.gz"
+md5sums=('98f57dbfca36b002b7b4df291f2f04cf')
+
+build() {
+ cd "$srcdir/ibus-$pkgver"
+ ./autogen.sh \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/ibus \
+ --sysconfdir=/etc \
+ --disable-gconf \
+ --enable-dconf \
+ --enable-wayland \
+ --disable-gtk-doc \
+ --disable-memconf \
+ --enable-ui \
+ --enable-python-library \
+ --with-python=python2
+ make
+}
+
+package() {
+ cd "$srcdir/ibus-$pkgver"
+ make DESTDIR="${pkgdir}" install
+ make -C src DESTDIR="${pkgdir}" uninstall
+ make -C bindings DESTDIR="${pkgdir}" uninstall
+ make DESTDIR="${pkgdir}" uninstall-pkgconfigDATA
+}
diff --git a/ibus.install b/ibus.install
new file mode 100644
index 000000000000..eea6deb6b3b3
--- /dev/null
+++ b/ibus.install
@@ -0,0 +1,20 @@
+post_install() {
+ gtk-query-immodules-2.0 --update-cache
+ gtk-query-immodules-3.0 --update-cache
+
+ gtk-update-icon-cache -fq -t usr/share/icons/hicolor
+
+ glib-compile-schemas usr/share/glib-2.0/schemas
+
+ dconf update
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+
+ rm -f etc/dconf/db/ibus
+}