summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2014-04-17 05:54:07 +0000
committerFelix Yan2014-04-17 05:54:07 +0000
commitd66b475f8b1274457fff6026ebebe434e937b82a (patch)
treef394c20e473eab5f9f45f0ec49c0481d87c66f56
parentbec6fee759dfe60b1c9d4fcacd68322deca98674 (diff)
downloadaur-d66b475f8b1274457fff6026ebebe434e937b82a.tar.gz
use python3 instead of python2
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecc9a9962057..dc9384bb43d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,21 +6,19 @@
pkgname=ibus-pinyin
pkgver=1.5.0
-pkgrel=2
+pkgrel=3
pkgdesc='Pinyin (Chinese) input method for the IBus framework'
arch=('i686' 'x86_64')
license=('GPL')
url='http://ibus.googlecode.com'
-depends=('ibus' 'pyzy' 'lua51')
+depends=('ibus' 'pyzy' 'lua51' 'python-xdg')
makedepends=('intltool')
source=("https://ibus.googlecode.com/files/${pkgname}-${pkgver}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
- sed -i -e "s|python|python2|" setup/ibus-setup-pinyin.in
-
- PYTHON=python2 ./configure \
+ ./configure \
--prefix=/usr \
--libexecdir=/usr/lib/ibus
@@ -28,8 +26,9 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd ${pkgname}-${pkgver}
make NO_INDEX=true DESTDIR="${pkgdir}" install
}
+
md5sums=('f7728b5b785fae58e2b4de8dfda45612')