summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-05-01 11:39:47 +0000
committerAntonio Rojas2019-05-01 11:39:47 +0000
commitbd4482d761cc406e0703f9375e4fbcbe422257f6 (patch)
tree282aa655b66cfc82a301b473d4e9a06270641444
downloadaur-bd4482d761cc406e0703f9375e4fbcbe422257f6.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0f6e5b0e267
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ibus-qt
+ pkgdesc = IBus qt library and IBus qt input method plugin
+ pkgver = 1.3.3
+ pkgrel = 13
+ url = http://ibus.googlecode.com
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = git
+ depends = qt4
+ depends = ibus
+ depends = icu
+ source = git+https://github.com/ibus/ibus-qt.git#tag=1.3.3
+ md5sums = SKIP
+
+pkgname = ibus-qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58d429d07f7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: garion < garion @ mailoo.org >
+# Contributor: leemars
+
+pkgname=ibus-qt
+pkgver=1.3.3
+pkgrel=13
+pkgdesc='IBus qt library and IBus qt input method plugin'
+arch=('x86_64')
+license=('LGPL')
+url='http://ibus.googlecode.com'
+depends=('qt4' 'ibus' 'icu')
+makedepends=('cmake' 'doxygen' 'git')
+source=("git+https://github.com/ibus/ibus-qt.git#tag=$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd $pkgname
+
+ make DESTDIR="${pkgdir}" install
+}
+