summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpescepalla2019-03-02 12:26:44 +0100
committerpescepalla2019-03-02 12:26:44 +0100
commit05f332abe327588eb1061b233de78ce25a41ea02 (patch)
tree0df7603a0d12e5908a4382b61b8ee44124db432f
parenta55936b5042919d653c8fcf6d1889486f0acc751 (diff)
downloadaur-05f332abe327588eb1061b233de78ce25a41ea02.tar.gz
version 2.6.0
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--PKGBUILD~58
3 files changed, 60 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b2a7ed6418c..e40a2936b705 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ibus-typing-booster-git
pkgdesc = A completion input method for faster typing, git version.
- pkgver = 2.5.3.r0.g00b015e
+ pkgver = git
pkgrel = 1
url = https://mike-fabian.github.io/ibus-typing-booster/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 33319f808f5b..f1f51f986ce1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='ibus-typing-booster-git'
pkgdesc='A completion input method for faster typing, git version.'
-pkgver=2.5.3.r0.g00b015e
+pkgver=git
pkgrel=1
url='https://mike-fabian.github.io/ibus-typing-booster/'
arch=('any')
diff --git a/PKGBUILD~ b/PKGBUILD~
new file mode 100644
index 000000000000..33319f808f5b
--- /dev/null
+++ b/PKGBUILD~
@@ -0,0 +1,58 @@
+# Maintainer: pescepalla <pescepalla@posteo.me>
+
+pkgname='ibus-typing-booster-git'
+pkgdesc='A completion input method for faster typing, git version.'
+pkgver=2.5.3.r0.g00b015e
+pkgrel=1
+url='https://mike-fabian.github.io/ibus-typing-booster/'
+arch=('any')
+license=('GNU3')
+makedepends=('git')
+
+depends=(
+ 'ibus'
+ 'm17n-lib'
+ 'python-dbus'
+ 'python-gobject'
+ 'sqlite'
+ )
+
+optdepends=(
+ 'python-pyenchant'
+ )
+
+provides=("ibus-typing-booster-git")
+conflicts=("ibus-typing-booster")
+source=("${pkgname}::git+https://github.com/mike-fabian/ibus-typing-booster.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+
+ git describe --long --tags \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ ./autogen.sh --prefix=/usr --libexecdir=/usr/lib/ibus
+ ./configure --prefix=/usr --libexecdir=/usr/lib/ibus
+ make
+}
+
+#check() {
+# cd "${pkgname}"
+# make check
+# }
+
+package() {
+ cd "${pkgname}"
+ #remove local schema if it exists because it may conflict with /usr/share/glib-2.0/schemas/org.freedesktop.ibus.engine.typing-booster.gschema.xml
+ SCHEMA="/usr/local/share/glib-2.0/schemas/org.freedesktop.ibus.engine.typing-booster.gschema.xml"
+ if [ -f $SCHEMA ]
+ then
+ rm $SCHEMA
+ fi
+ #install
+ make DESTDIR="$pkgdir/" install
+}