summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcodl2016-06-22 16:20:46 +0200
committercodl2016-06-22 16:20:46 +0200
commitd4d3cf98bf3e859549a44c797067ac9c48f4b3f6 (patch)
tree7dcf3d73c64c79bd722ae822ed805edc75d5dd2d
downloadaur-d4d3cf98bf3e859549a44c797067ac9c48f4b3f6.tar.gz
forked ibus-uniemoji-git into ibus-uniemoji
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bff02cdee5b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Jun 22 14:19:47 UTC 2016
+pkgbase = ibus-uniemoji
+ pkgdesc = A simple input method for ibus that allows you to enter unicode emoji and other symbols by name
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/lalomartins/ibus-uniemoji
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = libibus
+ optdepends = python-levenshtein: faster fuzzy search
+ conflicts = ibus-uniemoji-git
+ source = https://github.com/salty-horse/ibus-uniemoji/archive/v0.5.0.tar.gz
+ sha256sums = 647e3b2c3882ef87229f8272eadaaa08a532dfcfba0c563302efec1570df50ea
+
+pkgname = ibus-uniemoji
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a10069bd7920
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: codl <codl@codl.fr>
+# Contributor: Michael Lawson <mdlawson@gmx.com>
+
+pkgname=ibus-uniemoji
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="A simple input method for ibus that allows you to enter unicode emoji and other symbols by name"
+arch=(i686 x86_64)
+url="https://github.com/lalomartins/ibus-uniemoji"
+license=('GPL')
+depends=('python' 'libibus')
+makedepends=('git')
+conflicts=('ibus-uniemoji-git')
+optdepends=('python-levenshtein: faster fuzzy search')
+source=("https://github.com/salty-horse/ibus-uniemoji/archive/v${pkgver}.tar.gz")
+sha256sums=('647e3b2c3882ef87229f8272eadaaa08a532dfcfba0c563302efec1570df50ea')
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ mkdir -p $pkgdir/usr/share/ibus-uniemoji $pkgdir/etc/xdg/uniemoji
+ cp uniemoji.py uniemoji.svg UnicodeData.txt $pkgdir/usr/share/ibus-uniemoji
+ chmod a+x $pkgdir/usr/share/ibus-uniemoji/uniemoji.py
+ mkdir -p $pkgdir/usr/share/ibus/component
+ cp uniemoji.xml $pkgdir/usr/share/ibus/component
+}