summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2015-11-05 12:27:27 +0100
committerGeorg Schlisio2015-11-05 12:27:27 +0100
commit4d5aabb9798131b8b9e4cc8a727f37d83e44609c (patch)
tree824e6c7540f958c69a00000d5b631401d4bcaa4d
parent60fbf15407b5fc78d5885bcd76b7269a5eb2102e (diff)
downloadaur-4d5aabb9798131b8b9e4cc8a727f37d83e44609c.tar.gz
additional certificates as suggested in comments
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD134
2 files changed, 62 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9871a6a36a4..b23ab68d3d1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = icaclient
- pkgdesc = Citrix Receiver for Linux (ICAClient)
+ pkgdesc = Citrix Receiver for x86_64 (64bit) Linux (ICAClient)
pkgver = 13.2.1
- pkgrel = 3
+ pkgrel = 5
url = http://www.citrix.com/English/ps2/products/product.asp?contentID=1689163&ntref=prod_top
install = citrix-client.install
arch = x86_64
@@ -22,6 +22,7 @@ pkgbase = icaclient
depends = libxpm
depends = libxt
depends = ca-certificates
+ depends = nspluginwrapper
optdepends = xerces-c: gtk2 configuration manager
optdepends = webkitgtk2: gtk2 selfservice/storefront ui
conflicts = bin32-citrix-client
@@ -33,7 +34,7 @@ pkgbase = icaclient
source = wfica.desktop
source = wfica.sh
source = wfica_assoc.sh
- source = icaclient-13.2.1.tar.gz::http://downloads.citrix.com/10836/linuxx64-13.2.1.328635.tar.gz?__gda__=1443515288_49dce36201dead626d2689207b2f3d92
+ source = icaclient-13.2.1.tar.gz::http://downloads.citrix.com/10836/linuxx64-13.2.1.328635.tar.gz?__gda__=1446726418_edc49c2b2570c81933e9852efb62b6ea
md5sums = 71aca6257f259996ac59729604f32978
md5sums = a38c3f844a0fefe8017a25bee213b843
md5sums = 0e92c33b3fcc99b04269787da2984809
diff --git a/PKGBUILD b/PKGBUILD
index 64fb40762216..687c3266c654 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,20 @@
-# Maintainer: Daniele Vazzola <daniele.vazzola@gmail.com>
+# former Maintainer: Daniele Vazzola <daniele.vazzola@gmail.com>
# Contributor: CiarĂ¡n Coffey <ciaran@ccoffey.ie>
# Contributor: Matthew Gyurgyik <matthew@pyther.net>
pkgname=icaclient
pkgver=13.2.1
-pkgrel=3
-pkgdesc="Citrix Receiver for Linux (ICAClient)"
+pkgrel=5
+pkgdesc="Citrix Receiver for x86_64 (64bit) Linux (ICAClient)"
arch=('x86_64')
url="http://www.citrix.com/English/ps2/products/product.asp?contentID=1689163&ntref=prod_top"
license=('custom:Citrix')
-depends=(
- 'alsa-lib'
- 'libvorbis'
- 'curl'
- 'gtk2'
- 'libpng12'
- 'libxml2'
- 'libxaw'
- 'libxext'
- 'libxft'
- 'libxinerama'
- 'libxmu'
- 'libxp'
- 'libxpm'
- 'libxt'
- 'ca-certificates'
- #'nspluginwrapper'
-)
+depends=('alsa-lib' 'libvorbis' 'curl' 'gtk2' 'libpng12' 'libxml2' 'libxaw' 'libxext' 'libxft'
+ 'libxinerama' 'libxmu' 'libxp' 'libxpm' 'libxt' 'ca-certificates' 'nspluginwrapper')
optdepends=(
'xerces-c: gtk2 configuration manager'
- 'webkitgtk2: gtk2 selfservice/storefront ui'
-)
-
+ 'webkitgtk2: gtk2 selfservice/storefront ui')
conflicts=('bin32-citrix-client' 'citrix-client')
options=(!strip)
-
source_url="http:$(curl -L -silent 'http://www.citrix.com/downloads/citrix-receiver/linux/receiver-for-linux-1321.html' | awk -F 'rel=\"' '/linuxx64-/ {print $2}'| awk -F'"' '{print $1}'| sed '/^$/d' |uniq)"
source=('configmgr.desktop' 'conncenter.desktop' 'selfservice.desktop' 'wfica.desktop' 'wfica.sh' 'wfica_assoc.sh' $pkgname-$pkgver.tar.gz::$source_url)
makedepends=('wget')
@@ -44,60 +25,58 @@ md5sums=('71aca6257f259996ac59729604f32978'
'59f8e50cc0e0c399d47eb7ace1df5a32'
'dca5a1f51449ef35f1441b900d622276'
'd8f21201fae4a22605104f01ab9cf2da')
-
-
install=citrix-client.install
package() {
- cd "${srcdir}"
- ICAROOT=/opt/Citrix/ICAClient
-
- mkdir -p ${pkgdir}$ICAROOT
-
- cd "$srcdir/linuxx64/linuxx64.cor"
- install -m755 wfica *.so *.DLL AuthManagerDaemon PrimaryAuthManager ServiceRecord selfservice ${pkgdir}$ICAROOT
-
- # copy directories
- cp -r ./config/ ${pkgdir}$ICAROOT
- cp -r ./gtk/ ${pkgdir}$ICAROOT
- cp -r ./help/ ${pkgdir}$ICAROOT
- cp -r ./keyboard/ ${pkgdir}$ICAROOT
- cp -r ./keystore/ ${pkgdir}$ICAROOT
- cp -r ./lib/ ${pkgdir}$ICAROOT
- cp -r ./icons/ ${pkgdir}$ICAROOT
- cp -r ./nls/ ${pkgdir}$ICAROOT
- cp -r ./site/ ${pkgdir}$ICAROOT
- cp -r ./usb/ ${pkgdir}$ICAROOT
- cp -r ./util/ ${pkgdir}$ICAROOT
-
- # Intall License
- install -m644 -D nls/en/eula.txt \
- "${pkgdir}$ICAROOT/eula.txt"
-
- # create /config/.server to enable user customization using ~/.ICACLient/ overrides. Thanks Tomek
- touch ${pkgdir}$ICAROOT/config/.server
-
- # Extract system ca-certificates and install in the Citrix cacerts directory
- cp /etc/ca-certificates/extracted/tls-ca-bundle.pem ${pkgdir}$ICAROOT/keystore/cacerts/
- cd ${pkgdir}$ICAROOT/keystore/cacerts/
- awk 'BEGIN {c=0;} /BEGIN CERT/{c++} { print > "cert." c ".pem"}' < tls-ca-bundle.pem
-
- # The following 32-bit library causes false namcap errors
- # rm util/libgstflatstm.32.so
-
- # Install wrapper script
- install -m755 ${srcdir}/wfica.sh ${pkgdir}$ICAROOT/wfica.sh
-
- # Dirty Hack
- # wfica expects {module,wfclient,apssrv}.ini in $ICAROOT/config
- # sadly these configs differ slightly by locale
- lang=${LANG%%_*}
- if [[ ! -d ${pkgdir}/$ICAROOT/nls/$lang ]]; then
- lang='en'
- fi
- cp ${pkgdir}/$ICAROOT/nls/$lang/{appsrv.ini,module.ini,wfclient.ini} ${pkgdir}/$ICAROOT/config/
+ cd "${srcdir}"
+ ICAROOT=/opt/Citrix/ICAClient
+
+ mkdir -p ${pkgdir}$ICAROOT
+
+ cd "$srcdir/linuxx64/linuxx64.cor"
+ install -m755 wfica *.so *.DLL AuthManagerDaemon PrimaryAuthManager ServiceRecord selfservice ${pkgdir}$ICAROOT
+
+ # copy directories
+ cp -r ./config/ ${pkgdir}$ICAROOT
+ cp -r ./gtk/ ${pkgdir}$ICAROOT
+ cp -r ./help/ ${pkgdir}$ICAROOT
+ cp -r ./keyboard/ ${pkgdir}$ICAROOT
+ cp -r ./keystore/ ${pkgdir}$ICAROOT
+ cp -r ./lib/ ${pkgdir}$ICAROOT
+ cp -r ./icons/ ${pkgdir}$ICAROOT
+ cp -r ./nls/ ${pkgdir}$ICAROOT
+ cp -r ./site/ ${pkgdir}$ICAROOT
+ cp -r ./usb/ ${pkgdir}$ICAROOT
+ cp -r ./util/ ${pkgdir}$ICAROOT
+
+ # Install License
+ install -m644 -D nls/en/eula.txt \
+ "${pkgdir}$ICAROOT/eula.txt"
+
+ # create /config/.server to enable user customization using ~/.ICACLient/ overrides. Thanks Tomek
+ touch ${pkgdir}$ICAROOT/config/.server
+
+ # Extract system ca-certificates and install in the Citrix cacerts directory
+ cp /etc/ca-certificates/extracted/tls-ca-bundle.pem ${pkgdir}$ICAROOT/keystore/cacerts/
+ cd ${pkgdir}$ICAROOT/keystore/cacerts/
+ awk 'BEGIN {c=0;} /BEGIN CERT/{c++} { print > "cert." c ".pem"}' < tls-ca-bundle.pem
+
+ # The following 32-bit library causes false namcap errors
+ # rm util/libgstflatstm.32.so
+
+ # Install wrapper script
+ install -m755 ${srcdir}/wfica.sh ${pkgdir}$ICAROOT/wfica.sh
+
+ # Dirty Hack
+ # wfica expects {module,wfclient,apssrv}.ini in $ICAROOT/config
+ # sadly these configs differ slightly by locale
+ lang=${LANG%%_*}
+ if [[ ! -d ${pkgdir}/$ICAROOT/nls/$lang ]]; then
+ lang='en'
+ fi
+ cp ${pkgdir}/$ICAROOT/nls/$lang/{appsrv.ini,module.ini,wfclient.ini} ${pkgdir}/$ICAROOT/config/
-# Copy Firefox plugin into plugin directory
+ # Copy Firefox plugin into plugin directory
mkdir -p "${pkgdir}/usr/lib/mozilla/plugins"
ln -s "$ICAROOT/npica.so" "${pkgdir}"/usr/lib/mozilla/plugins/npica.so
cd "${srcdir}"
@@ -110,5 +89,8 @@ package() {
install -Dm755 wfica.sh "${pkgdir}$ICAROOT"
install -Dm755 wfica_assoc.sh "${pkgdir}$ICAROOT"
-}
+ # make certificates available
+ ln -s "${pkgdir}/usr/share/ca-certificates/trust-source/*" "${pkgdir}/opt/Citrix/ICAClient/keystore/cacerts/"
+ c_rehash "${pkgdir}/opt/Citrix/ICAClient/keystore/cacerts/"
+}