summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgéballin2019-01-27 19:33:15 +0100
committergéballin2019-01-27 19:33:15 +0100
commitc8125500d7532987a59252b187b95d34b3df8c04 (patch)
treecbefae0df3f03353b7cc1bc718a3fd90b21b50f8
downloadaur-c8125500d7532987a59252b187b95d34b3df8c04.tar.gz
First commit of ical.
Version 3.0.3 .
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7d80a469e0a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ical
+ pkgdesc = ical is an old but popular calendar package written in Tcl by Sanjay Ghemawat for Unix systems.
+ pkgver = 3.0.3
+ pkgrel = 1
+ url = https://launchpad.net/ical-tcl
+ arch = x86_64
+ arch = i686
+ license = GPLv2
+ makedepends = gcc
+ makedepends = make
+ depends = tcl
+ depends = tk
+ source = https://launchpad.net/ical-tcl/3.x/3.0.3/+download/ical-3.0.3.tar.gz
+ md5sums = 0aa41a0501a7db8d4eb31867f68aa36b
+
+pkgname = ical
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..941330e46a9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
+pkgname=ical
+pkgver=3.0.3
+pkgrel=1
+pkgdesc="ical is an old but popular calendar package written in Tcl by Sanjay Ghemawat for Unix systems."
+url="https://launchpad.net/ical-tcl"
+arch=('x86_64' 'i686')
+license=('GPLv2')
+depends=(tcl tk)
+optdepends=()
+makedepends=(gcc make)
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("https://launchpad.net/ical-tcl/3.x/3.0.3/+download/ical-3.0.3.tar.gz")
+
+md5sums=('0aa41a0501a7db8d4eb31867f68aa36b')
+
+build() {
+ tar xzf ical-${pkgver}.tar.gz
+ cd ical-${pkgver}
+ ./configure --prefix=/usr
+ make
+ }
+
+package() {
+ cd ical-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ }