summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-20 11:29:05 +0800
committerzxp198210052023-12-20 11:29:05 +0800
commitad2dd13ac9fdef023536c8e64a326a5bc37e1f67 (patch)
tree5c7799dae8a4176373db819a972579121a4bb684
parent184eb7f5c03f82837801be1adfd20946a0b72a24 (diff)
downloadaur-ad2dd13ac9fdef023536c8e64a326a5bc37e1f67.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
-rw-r--r--icalingua++.sh19
3 files changed, 36 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 252ddaab2788..fca3d61a14b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = icalingua++-bin
pkgdesc = A branch of deleted Icalingua, with limited support
pkgver = 2.10.10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Icalingua-plus-plus/Icalingua-plus-plus
arch = aarch64
arch = armv7h
arch = x86_64
license = AGPL3
- depends = bash
depends = electron22
provides = icalingua++=2.10.10
conflicts = icalingua++
conflicts = icalingua++-electron
- source = icalingua++.png::https://raw.githubusercontent.com/Icalingua-plus-plus/Icalingua-plus-plus/develop/pkgres/512x512.png
- source = icalingua++.desktop::https://raw.githubusercontent.com/Icalingua-plus-plus/Icalingua-plus-plus/develop/pkgres/icalingua.desktop
+ source = icalingua++-2.10.10.png::https://raw.githubusercontent.com/Icalingua-plus-plus/Icalingua-plus-plus/develop/pkgres/512x512.png
+ source = icalingua++-2.10.10.desktop::https://raw.githubusercontent.com/Icalingua-plus-plus/Icalingua-plus-plus/develop/pkgres/icalingua.desktop
source = icalingua++.sh
sha256sums = 5743ef3d19be5e41e83c3a1171a807cd0505d7f5d5f9c5abdff8926dccadc6de
sha256sums = b088d20934708c53e50492694efefbf9a9dcb62fefb8d1d4976f36f32f84af86
- sha256sums = c3cf01f71ea0004d31b759816a72694b2a64c3fb437c50c264646f7d524dce80
+ sha256sums = 68521cf799a902fb3c86aa1ebdcfa92566ee49621b0e1db5873a0501d893b2e6
source_aarch64 = icalingua++-2.10.10-aarch64.asar::https://github.com/Icalingua-plus-plus/Icalingua-plus-plus/releases/download/v2.10.10/app-arm64.asar
sha256sums_aarch64 = 710a76bccc2b25ed4963fec9a4a91ec5cf97e0036d66d4fdbc5dbbf4a9ce6c17
source_armv7h = icalingua++-2.10.10-armv7h.asar::https://github.com/Icalingua-plus-plus/Icalingua-plus-plus/releases/download/v2.10.10/app-armv7l.asar
diff --git a/PKGBUILD b/PKGBUILD
index ce99bcd56019..343d498a1e4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,44 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=icalingua++-bin
pkgver=2.10.10
-pkgrel=1
+_electronversion=22
+pkgrel=2
pkgdesc="A branch of deleted Icalingua, with limited support"
arch=("aarch64" "armv7h" "x86_64")
url="https://github.com/Icalingua-plus-plus/Icalingua-plus-plus"
license=("AGPL3")
provides=("${pkgname%-bin}=${pkgver}")
-conflicts=("${pkgname%-bin}" "${pkgname%-bin}-electron")
+conflicts=(
+ "${pkgname%-bin}"
+ "${pkgname%-bin}-electron"
+)
depends=(
- 'bash'
- 'electron22'
+ "electron${_electronversion}"
)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.asar::${url}/releases/download/v${pkgver}/app-arm64.asar")
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.asar::${url}/releases/download/v${pkgver}/app-armv7l.asar")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.asar::${url}/releases/download/v${pkgver}/app-x86_64.asar")
-source=("${pkgname%-bin}.png::https://raw.githubusercontent.com/Icalingua-plus-plus/Icalingua-plus-plus/develop/pkgres/512x512.png"
- "${pkgname%-bin}.desktop::https://raw.githubusercontent.com/Icalingua-plus-plus/Icalingua-plus-plus/develop/pkgres/icalingua.desktop"
- "${pkgname%-bin}.sh")
+source=(
+ "${pkgname%-bin}-${pkgver}.png::https://raw.githubusercontent.com/Icalingua-plus-plus/Icalingua-plus-plus/develop/pkgres/512x512.png"
+ "${pkgname%-bin}-${pkgver}.desktop::https://raw.githubusercontent.com/Icalingua-plus-plus/Icalingua-plus-plus/develop/pkgres/icalingua.desktop"
+ "${pkgname%-bin}.sh"
+)
sha256sums=('5743ef3d19be5e41e83c3a1171a807cd0505d7f5d5f9c5abdff8926dccadc6de'
'b088d20934708c53e50492694efefbf9a9dcb62fefb8d1d4976f36f32f84af86'
- 'c3cf01f71ea0004d31b759816a72694b2a64c3fb437c50c264646f7d524dce80')
+ '68521cf799a902fb3c86aa1ebdcfa92566ee49621b0e1db5873a0501d893b2e6')
sha256sums_aarch64=('710a76bccc2b25ed4963fec9a4a91ec5cf97e0036d66d4fdbc5dbbf4a9ce6c17')
sha256sums_armv7h=('1b7bb1aad909940bcd9ddb618d3a9d8d2c957998f039885e5b01345019d878f6')
sha256sums_x86_64=('697594fac88b699f90b14e235c94f9d2125945217700a5f6c5e140bd2a07008b')
build() {
- sed "s|${pkgname%++-bin} %u|${pkgname%-bin}|g;s|${pkgname%++-bin}.png|${pkgname%-bin}|g" -i "${srcdir}/${pkgname%-bin}.desktop"
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ sed "s|${pkgname%++-bin}.png|${pkgname%-bin}|g" -i "${srcdir}/${pkgname%-bin}-${pkgver}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.asar" "${pkgdir}/usr/lib/${pkgname%-bin}/app.asar"
- install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
- install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
} \ No newline at end of file
diff --git a/icalingua++.sh b/icalingua++.sh
index 357f7f7bca43..98f84b151b4f 100644
--- a/icalingua++.sh
+++ b/icalingua++.sh
@@ -1,10 +1,15 @@
-#!/bin/bash
-_ELECTRON=/usr/bin/electron22
-APPDIR="/usr/lib/icalingua++"
-export PATH="${APPDIR}:${PATH}"
-_ASAR="${APPDIR}/app.asar"
+#!/bin/sh
+set -e
+_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} --dha "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- exec ${_ELECTRON} ${_ASAR} --dha --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
fi \ No newline at end of file