summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang Hua2023-09-11 09:37:33 +0800
committerZhang Hua2023-09-11 09:37:33 +0800
commit692d161d5921b5377cc2005b0a93b706af191d51 (patch)
treef4b2389780cfe7b6219897eefabd9a393ba393f3
parentdeb276df1acb529bb4af516f98d3129332ed45f5 (diff)
downloadaur-692d161d5921b5377cc2005b0a93b706af191d51.tar.gz
Add missing depends of electron
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD19
2 files changed, 53 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec4cc99d18d2..a1f6dc45b8ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = icalingua++-git
pkgdesc = A Linux client for QQ and more(fork to upgrading)
- pkgver = 2.9.12.r1.gb626dcdf
+ pkgver = 2.10.3.r0.gf1d164ff
pkgrel = 1
url = https://github.com/Icalingua-plus-plus/Icalingua-plus-plus
arch = aarch64
@@ -24,13 +24,47 @@ pkgbase = icalingua++-git
sha256sums = SKIP
pkgname = icalingua++-git
+ depends = ffmpeg
+ depends = libappindicator-gtk3
+ depends = libvips
+ depends = c-ares
+ depends = gtk3
+ depends = libevent
+ depends = nss
+ depends = wayland
+ depends = fontconfig
+ depends = woff2
+ depends = aom
+ depends = brotli
+ depends = libjpeg
+ depends = icu
+ depends = dav1d
+ depends = flac
+ depends = snappy
+ depends = libxml2
+ depends = ffmpeg
+ depends = libwebp
+ depends = minizip
+ depends = opus
+ depends = harfbuzz
+ depends = jsoncpp
+ depends = libxslt
+ depends = libpng
+ depends = freetype2
+ optdepends = mongodb: Provides storage
+ optdepends = redis: Provides storage
+ optdepends = kde-cli-tools: file deletion support (kioclient5)
+ optdepends = pipewire: WebRTC desktop sharing under Wayland
+ optdepends = qt5-base: enable Qt5 with --enable-features=AllowQt
+ optdepends = trash-cli: file deletion support (trash-put)
+ optdepends = xdg-utils: open URLs with desktop’s default (xdg-email, xdg-open)
pkgname = icalingua++-electron-git
pkgdesc = A Linux client for QQ and more(fork to upgrading) with system electron
depends = ffmpeg
depends = libappindicator-gtk3
depends = libvips
- depends = electron21
+ depends = electron22
provides = electron-qq
provides = icalingua
provides = icalingua-electron
diff --git a/PKGBUILD b/PKGBUILD
index 870cd43e1871..d40ac083c621 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Clansty <i at gao4 dot pw>
pkgname=("icalingua++-git" "icalingua++-electron-git")
-pkgver=2.9.12.r1.gb626dcdf
+pkgver=2.10.3.r0.gf1d164ff
pkgrel=1
pkgdesc='A Linux client for QQ and more(fork to upgrading)'
license=('AGPL')
@@ -18,7 +18,7 @@ conflicts=('electron-qq' 'icalingua')
replaces=('electron-qq')
source=("Icalingua::git+${url}#branch=develop")
sha256sums=('SKIP')
-_electron=electron21
+_electron=electron22
pkgver(){
cd "${srcdir}/Icalingua"
@@ -40,6 +40,21 @@ build(){
pnpm run build:dir
}
package_icalingua++-git(){
+ depends+=(
+ # Electron depends
+ "c-ares" "gtk3" "libevent" "nss" "wayland" "fontconfig"
+ "woff2" "aom" "brotli" "libjpeg" "icu" "dav1d" "flac"
+ "snappy" "libxml2" "ffmpeg" "libwebp" "minizip" "opus"
+ "harfbuzz" "jsoncpp" "libxslt" "libpng" "freetype2"
+ )
+ optdepends+=(
+ # Electron optdepends
+ "kde-cli-tools: file deletion support (kioclient5)"
+ "pipewire: WebRTC desktop sharing under Wayland"
+ "qt5-base: enable Qt5 with --enable-features=AllowQt"
+ "trash-cli: file deletion support (trash-put)"
+ "xdg-utils: open URLs with desktop’s default (xdg-email, xdg-open)"
+ )
case ${CARCH} in
"x86_64")
_arch="-";;