summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhanghua0002022-05-20 18:14:29 +0800
committerzhanghua0002022-05-20 18:14:29 +0800
commit992b025bd466c14fd193acbbf3c61f36ccfe38f3 (patch)
tree72c71cfe45c8daa1ec0564b8092c4d53beeb0de1
parent7ff682e15e4d1cd681ac69bc50d368198f1dc3ce (diff)
downloadaur-992b025bd466c14fd193acbbf3c61f36ccfe38f3.tar.gz
Upgrade to latest version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9683a9909e15..dbedc7746c38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = icalingua++-git
pkgdesc = A Linux client for QQ and more(fork to upgrading)
- pkgver = 2.6.1.r2.gef15421
+ pkgver = 2.6.3.r1.gd070477
pkgrel = 1
url = https://github.com/Icalingua-plus-plus/Icalingua-plus-plus
arch = aarch64
@@ -27,7 +27,7 @@ pkgname = icalingua++-electron-git
pkgdesc = A Linux client for QQ and more(fork to upgrading) with system electron
depends = ffmpeg
depends = libappindicator-gtk3
- depends = electron17
+ depends = electron
provides = electron-qq
provides = icalingua
provides = icalingua-electron
diff --git a/PKGBUILD b/PKGBUILD
index 63340c7dc382..32d705a32d9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Clansty <i at gao4 dot pw>
pkgname=("icalingua++-git" "icalingua++-electron-git")
-pkgver=2.6.1.r2.gef15421
+pkgver=2.6.3.r1.gd070477
pkgrel=1
pkgdesc='A Linux client for QQ and more(fork to upgrading)'
license=('AGPL')
@@ -18,7 +18,7 @@ conflicts=('electron-qq' 'icalingua')
replaces=('electron-qq')
source=("Icalingua::git+${url}")
sha256sums=('SKIP')
-_electron=electron17
+_electron=electron
pkgver(){
cd "${srcdir}/Icalingua"
@@ -75,5 +75,5 @@ package_icalingua++-electron-git(){
install -Dm644 512x512.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/icalingua.png"
install -Dm644 icalingua.desktop "${pkgdir}/usr/share/applications/icalingua.desktop"
install -Dm755 icalingua "${pkgdir}/usr/bin/icalingua"
- #sed -i "s/electron/${_electron}/" "${pkgdir}/usr/bin/icalingua"
+ sed -i "s/electron.* /${_electron} /" "${pkgdir}/usr/bin/icalingua"
}