summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhanghua0002022-08-18 10:19:28 +0800
committerzhanghua0002022-08-18 10:19:28 +0800
commitbfcfa53ceac2f7ba76ef7f7196320469c79b59b1 (patch)
tree64b7c3080d9974013ac9fe311df1fd16becb5b3c
parentc1ee0444d95a4c23a6db9772138dd6d072536258 (diff)
downloadaur-bfcfa53ceac2f7ba76ef7f7196320469c79b59b1.tar.gz
Fix build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3778429a4fb6..c51f385aa6bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = icalingua++-git
pkgdesc = A Linux client for QQ and more(fork to upgrading)
- pkgver = 2.6.4.r0.g25b4423
+ pkgver = 2.6.6.r31.g8dff371
pkgrel = 1
url = https://github.com/Icalingua-plus-plus/Icalingua-plus-plus
arch = aarch64
arch = x86_64
arch = i686
license = AGPL
- makedepends = yarn
+ makedepends = nodejs
makedepends = git
depends = ffmpeg
depends = libappindicator-gtk3
diff --git a/PKGBUILD b/PKGBUILD
index 971a31caa574..525def35e196 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
# Contributor: Clansty <i at gao4 dot pw>
pkgname=("icalingua++-git" "icalingua++-electron-git")
-pkgver=2.6.4.r0.g25b4423
+pkgver=2.6.6.r31.g8dff371
pkgrel=1
pkgdesc='A Linux client for QQ and more(fork to upgrading)'
license=('AGPL')
depends=('ffmpeg' 'libappindicator-gtk3')
-makedepends=('yarn' 'git')
+makedepends=('nodejs' 'git')
optdepends=('mongodb-bin: Provides storage'
'redis: Provides storage')
arch=('aarch64' 'x86_64' 'i686')
@@ -24,13 +24,12 @@ pkgver(){
cd "${srcdir}/Icalingua"
git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./g'
}
-prepare(){
- cd "${srcdir}/Icalingua/icalingua"
- yarn install --immutable
-}
+
build(){
- cd "${srcdir}/Icalingua/icalingua"
- yarn run build:dir
+ cd "${srcdir}/Icalingua"
+ node /usr/lib/node_modules/corepack/dist/pnpm.js install
+ cd icalingua
+ node /usr/lib/node_modules/corepack/dist/pnpm.js run build:dir
}
package_icalingua++-git(){
case ${CARCH} in