summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPig Fang2020-09-24 17:23:56 +0800
committerPig Fang2020-09-24 17:25:24 +0800
commit9c09e709f5c1f353958e2992b8ef52baa4e6ac69 (patch)
tree6858fe84905506901c38530ac12a5f4acc0d58b4
downloadaur-9c09e709f5c1f353958e2992b8ef52baa4e6ac69.tar.gz
v0.1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..893e0f89e85e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = icd
+ pkgdesc = Powerful `cd` command with fuzzy-search tool.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/g-plane/icd
+ arch = any
+ license = MIT
+ depends = zsh
+ optdepends = fzy
+ optdepends = ripgrep
+ source = https://github.com/g-plane/icd/archive/v0.1.0.tar.gz
+ sha256sums = 3691ad0215e4f2d2f9a0b3080b7be7dee9d8e694412b1decf2ed2eca9786fb0d
+
+pkgname = icd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41fd0756d77e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Pig Fang <g-plane@hotmail.com>
+pkgname=icd
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Powerful `cd` command with fuzzy-search tool.'
+
+arch=('any')
+url="https://github.com/g-plane/$pkgname"
+source=("https://github.com/g-plane/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('3691ad0215e4f2d2f9a0b3080b7be7dee9d8e694412b1decf2ed2eca9786fb0d')
+license=('MIT')
+depends=('zsh')
+optdepends=('fzy'
+ 'ripgrep')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver/
+ mkdir -p $pkgdir/usr/share/zsh/scripts/$pkgname/
+ cp $pkgname.plguin.zsh $pkgdir/usr/share/zsh/scripts/$pkgname/
+
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname/
+ cp ./LICENSE $pkgdir/usr/share/licenses/$pkgname/
+}