summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPig Fang2024-02-19 10:54:55 +0800
committerPig Fang2024-02-19 10:54:55 +0800
commitac97097e71c20f726d5a22e04f77f2ffe7127988 (patch)
treeafdd906bd5cd5da8843228b8387e8cfbb6ebccba
parent056fec30f0aa93dc32151c2c85923c23204d7c74 (diff)
downloadaur-ac97097e71c20f726d5a22e04f77f2ffe7127988.tar.gz
0.2.0-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cde3aba99b3..257fa346cca7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = icd
pkgdesc = Powerful `cd` command with fuzzy-search tool.
- pkgver = 0.1.1
- pkgrel = 3
+ pkgver = 0.2.0
+ pkgrel = 1
url = https://github.com/g-plane/icd
arch = any
license = MIT
- depends = zsh
- optdepends = fzy
- optdepends = fzf
+ depends = fzf
optdepends = ripgrep
optdepends = grep
- source = https://github.com/g-plane/icd/archive/v0.1.1.tar.gz
+ source = https://github.com/g-plane/icd/archive/v0.2.0.tar.gz
sha256sums = 4ad64ebd0afcb99f8def17044d2255c34fd3bdf16683ff938829b64a1048fdf2
pkgname = icd
-
diff --git a/PKGBUILD b/PKGBUILD
index 459638ace4f9..c0d5f05ad54e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pig Fang <g-plane@hotmail.com>
pkgname=icd
-pkgver=0.1.1
-pkgrel=3
+pkgver=0.2.0
+pkgrel=1
pkgdesc='Powerful `cd` command with fuzzy-search tool.'
arch=('any')
@@ -9,12 +9,14 @@ url="https://github.com/g-plane/$pkgname"
source=("https://github.com/g-plane/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('4ad64ebd0afcb99f8def17044d2255c34fd3bdf16683ff938829b64a1048fdf2')
license=('MIT')
-depends=('zsh')
-optdepends=('fzy' 'fzf' 'ripgrep' 'grep')
+depends=('fzf')
+optdepends=('ripgrep' 'grep')
package() {
cd $srcdir/$pkgname-$pkgver/
install -Dm644 $pkgname.plugin.zsh $pkgdir/usr/share/zsh/scripts/$pkgname/$pkgname.plugin.zsh
+ install -dm755 $pkgdir/usr/share/fish/vendor_functions.d
+ install -Dm644 icd.fish $pkgdir/usr/share/fish/vendor_functions.d/icd.fish
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}