summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-05-10 15:53:38 +0200
committerKr1ss2021-05-10 15:53:38 +0200
commitb973173d9733a19996ae6e765436658a28bfc786 (patch)
tree99386fca778cbeda654284e330f20e3a143166eb
parent4ead43cc2a97e8fe4b0c51a9a7639001c0d4e958 (diff)
downloadaur-b973173d9733a19996ae6e765436658a28bfc786.tar.gz
adapt patch to upstream update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
-rw-r--r--ice.patch12
3 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 753a48b8518a..efc232fd3228 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ice-ssb-git
pkgdesc = Desktop integration for webapps
- pkgver = 6.0.8.r26.499b891
- pkgrel = 3
+ pkgver = 6.0.8.r30.5ddfc8e
+ pkgrel = 1
url = https://github.com/peppermintos/ice
arch = any
license = GPL2
@@ -22,7 +22,7 @@ pkgbase = ice-ssb-git
source = git+https://github.com/peppermintos/ice.git
source = ice.patch
sha256sums = SKIP
- sha256sums = b7ca85f38fb7dd9369d069ab1969d082fda6f23f16218fe13c3b69c9f886f8b6
+ sha256sums = 1b3ba9c290faa8a9f2c8caf6c754378ac7ae82cf1117318a115e075b800c10d3
pkgname = ice-ssb-git
diff --git a/PKGBUILD b/PKGBUILD
index 58e6170d2bd2..ad18331129a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,44 @@
# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
-_pkgname=ice
+_name=ice
pkgname=ice-ssb-git
pkgver() {
- git -C "$_pkgname" describe --tags | sed 's/v\?\([^-]\+\)-/\1.r/;s/-g/./'
+ git -C "$_name" describe --tags | sed 's/v\?\([^-]\+\)-/\1.r/;s/-g/./'
}
-pkgver=6.0.8.r26.499b891
-pkgrel=3
+pkgver=6.0.8.r30.5ddfc8e
+pkgrel=1
pkgdesc='Desktop integration for webapps'
-url="https://github.com/peppermintos/$_pkgname"
+url="https://github.com/peppermintos/$_name"
arch=('any')
license=('GPL2')
-provides=("${pkgname%-git}" "$_pkgname")
-conflicts=("${pkgname%-git}" "$_pkgname")
+provides=("${pkgname%-git}" "$_name")
+conflicts=("${pkgname%-git}" "$_name")
makedepends=('git')
depends=('python-requests' 'python-beautifulsoup4' 'python-gobject' 'python-lxml')
optdepends=('brave' 'firefox' 'chromium' 'google-chrome' 'vivaldi')
-source=("git+$url.git" "$_pkgname.patch")
+source=("git+$url.git" "$_name.patch")
sha256sums=('SKIP'
- 'b7ca85f38fb7dd9369d069ab1969d082fda6f23f16218fe13c3b69c9f886f8b6')
+ '1b3ba9c290faa8a9f2c8caf6c754378ac7ae82cf1117318a115e075b800c10d3')
prepare() {
- cd "$_pkgname"
+ cd "$_name"
# patch browser binary filenames to match Archlinux packages
- patch --no-backup-if-mismatch -Np1 <"../$_pkgname.patch"
+ patch --verbose -Np1 <"../$_name.patch"
# delete PeppermintOS specific assets
rm -r usr/lib
}
package() {
- cd "$_pkgname"
+ cd "$_name"
cp -a --no-preserve=o usr "$pkgdir/"
- install -Dm644 README.md -t"$pkgdir/usr/share/doc/$_pkgname/"
+ install -Dm644 README.md -t"$pkgdir/usr/share/doc/$_name/"
}
diff --git a/ice.patch b/ice.patch
index 70a791049f98..267a4f40ae48 100644
--- a/ice.patch
+++ b/ice.patch
@@ -1,7 +1,7 @@
-diff -ru --color old/usr/bin/ice new/usr/bin/ice
---- old/usr/bin/ice 2020-08-06 16:16:29.766880323 +0200
-+++ new/usr/bin/ice 2020-08-06 16:18:03.276808705 +0200
-@@ -44,8 +44,8 @@
+diff -rpu --color old/usr/bin/ice new/usr/bin/ice
+--- old/usr/bin/ice 2021-05-10 15:47:34.278040167 +0200
++++ new/usr/bin/ice 2021-05-10 15:48:35.098265219 +0200
+@@ -44,8 +44,8 @@ _EPIPHANY_PROFILES_DIR = "{0}/epiphany".
_ICE_ICON = "/usr/share/pixmaps/ice.png"
_ICON_DIR = "{0}/icons".format(_ICE_DIR)
_BRAVE_BIN = "/usr/bin/brave-browser"
@@ -11,8 +11,8 @@ diff -ru --color old/usr/bin/ice new/usr/bin/ice
+_CHROMIUM_BIN = "/usr/bin/chromium"
_VIVALDI_BIN = "/usr/bin/vivaldi-stable"
_FIREFOX_BIN = "/usr/bin/firefox"
- _EPIPHANY_BIN = "/usr/bin/epiphany-browser"
-@@ -703,7 +703,7 @@
+ _EPIPHANY_BIN = "/usr/bin/epiphany"
+@@ -699,7 +699,7 @@ class Ice(Gtk.Window):
if self.chrome.get_active() is True:
self.browser = "google-chrome"
elif self.chromium.get_active() is True: