summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2016-06-14 17:09:13 -0700
committerShadowKyogre2016-06-14 17:09:13 -0700
commit951bf34a0b66f305cd4bac76f7f26e3a8d571f93 (patch)
tree10370230bea751a2bc9c1aac3a38fd4d813561aa
parentcb07501c47d1278850903a2ceb2556fab8a01c10 (diff)
downloadaur-951bf34a0b66f305cd4bac76f7f26e3a8d571f93.tar.gz
Update for orphaning
- Allow x86_64 arch builds - Run make clean before building - Add package() function
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa20ee743062..d958579b8be9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,12 @@
+# Generated by mksrcinfo v8
+# Wed Jun 15 00:09:01 UTC 2016
pkgbase = icebreaker
pkgdesc = A clone of Jezzball that uses icebergs and penguins. (non-theme support version)
pkgver = 1.2.1
- pkgrel = 2
+ pkgrel = 3
url = http://mattdm.org/icebreaker/
arch = i686
+ arch = x86_64
license = GPL
depends = sdl_mixer
source = http://mattdm.org/icebreaker/1.2.x/icebreaker-1.2.1.tgz
diff --git a/PKGBUILD b/PKGBUILD
index fd3e5042031e..90b76910cbcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Contributor: ShadowKyogre <shadowkyogre@writing.com>
+# Contributor: Sapphira Armageddos <shadowkyogre.public@gmail.com>
pkgname=icebreaker
pkgver=1.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="A clone of Jezzball that uses icebergs and penguins. (non-theme support version)"
-arch=('i686')
+arch=('i686' 'x86_64')
url="http://mattdm.org/icebreaker/"
license=('GPL')
depends=('sdl_mixer')
@@ -14,8 +14,13 @@ md5sums=('9453119cf3342a8828e4805c0c49be50'
build() {
cd "$srcdir/$pkgname-$pkgver"
patch -Np1 -i ../icebreaker.patch || return 1
+ make clean
make highscoredir=/var/lib/games prefix=/usr || return 1
- make prefix=$pkgdir/usr install highscoredir=$pkgdir/var/lib/games || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make prefix="$pkgdir/usr" install "highscoredir=$pkgdir/var/lib/games" || return 1
}
# vim:set ts=2 sw=2 et: