summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2021-01-01 22:21:39 +0100
committerJoan Figueras2021-01-01 22:21:39 +0100
commit20765d3619a2cc8cd99ac3476c7cbd400a399376 (patch)
tree984af3faf1100a36ef4ce3f60c645d01f331e7d1
parentadc3ddafbb33abb9e2cf8f42d7b09d87b68db376 (diff)
downloadaur-20765d3619a2cc8cd99ac3476c7cbd400a399376.tar.gz
Fix cbindgen 0.16.0 build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--cbindgen-0.16.patch25
3 files changed, 35 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f6138b5b80c..37c72192c914 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = icecat
pkgdesc = GNU version of the Firefox browser.
pkgver = 78.6.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.gnu.org/software/gnuzilla/
arch = x86_64
license = GPL
@@ -55,11 +55,13 @@ pkgbase = icecat
source = icecat-safe.desktop
source = 0001-Use-remoting-name-for-GDK-application-names.patch::https://raw.githubusercontent.com/archlinux/svntogit-packages/0adcedc05ce67d53268575f8801c8de872206901/firefox/trunk/0001-Use-remoting-name-for-GDK-application-names.patch
source = rust_1.48.patch.gz
+ source = cbindgen-0.16.patch
sha256sums = d8938711584023476abb88d93bd36a7141ecdf4ac890e71ebc0666caad93775e
sha256sums = e00dbf01803cdd36fd9e1c0c018c19bb6f97e43016ea87062e6134bdc172bc7d
sha256sums = 33dd309eeb99ec730c97ba844bf6ce6c7840f7d27da19c82389cdefee8c20208
sha256sums = e0eaec8ddd24bbebf4956563ebc6d7a56f8dada5835975ee4d320dd3d0c9c442
sha256sums = d32c87c4526e897d64453914da43f99366d1d0b7d71e43b4027a6cb5aa274040
+ sha256sums = ea348e96620d6ba10f3d41fbb18def98847b6172b0028aacc26f099f47727796
pkgname = icecat
diff --git a/PKGBUILD b/PKGBUILD
index 64fc48b52ec6..39a0af501f41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=icecat
pkgver=78.6.0
-pkgrel=1
+pkgrel=2
_commit=a43514623e93d4f3fe6d61f5b2f82c5ef29bf518
pkgdesc="GNU version of the Firefox browser."
arch=(x86_64)
@@ -27,13 +27,14 @@ options=(!emptydirs !makeflags !strip)
source=(https://git.savannah.gnu.org/cgit/gnuzilla.git/snapshot/gnuzilla-${_commit}.tar.gz
icecat.desktop icecat-safe.desktop
"0001-Use-remoting-name-for-GDK-application-names.patch::https://raw.githubusercontent.com/archlinux/svntogit-packages/0adcedc05ce67d53268575f8801c8de872206901/firefox/trunk/0001-Use-remoting-name-for-GDK-application-names.patch"
- rust_1.48.patch.gz)
+ rust_1.48.patch.gz cbindgen-0.16.patch)
sha256sums=('d8938711584023476abb88d93bd36a7141ecdf4ac890e71ebc0666caad93775e'
'e00dbf01803cdd36fd9e1c0c018c19bb6f97e43016ea87062e6134bdc172bc7d'
'33dd309eeb99ec730c97ba844bf6ce6c7840f7d27da19c82389cdefee8c20208'
'e0eaec8ddd24bbebf4956563ebc6d7a56f8dada5835975ee4d320dd3d0c9c442'
- 'd32c87c4526e897d64453914da43f99366d1d0b7d71e43b4027a6cb5aa274040')
+ 'd32c87c4526e897d64453914da43f99366d1d0b7d71e43b4027a6cb5aa274040'
+ 'ea348e96620d6ba10f3d41fbb18def98847b6172b0028aacc26f099f47727796')
prepare() {
cd gnuzilla-${_commit}
@@ -103,6 +104,9 @@ EOF
# https://bugzilla.mozilla.org/show_bug.cgi?id=1667736
patch -Np1 -i ../../../rust_1.48.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1684180
+ patch -Np1 -i ../../../cbindgen-0.16.patch
+
# Patch to move files directly to /usr/lib/icecat. No more symlinks.
sed -e 's;$(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION);$(libdir)/$(MOZ_APP_NAME);g' -i config/baseconfig.mk
sed -e 's;$(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION);$(libdir)/$(MOZ_APP_NAME)-devel;g' -i config/baseconfig.mk
diff --git a/cbindgen-0.16.patch b/cbindgen-0.16.patch
new file mode 100644
index 000000000000..c562a49838e7
--- /dev/null
+++ b/cbindgen-0.16.patch
@@ -0,0 +1,25 @@
+diff --git a/dom/webgpu/ipc/WebGPUParent.cpp b/dom/webgpu/ipc/WebGPUParent.cpp
+--- a/dom/webgpu/ipc/WebGPUParent.cpp
++++ b/dom/webgpu/ipc/WebGPUParent.cpp
+@@ -423,17 +423,15 @@
+ switch (entry.mType) {
+ case SerialBindGroupEntryType::Buffer:
+ bgb.resource.tag = ffi::WGPUBindingResource_Buffer;
+- bgb.resource.buffer._0.buffer = entry.mValue;
+- bgb.resource.buffer._0.offset = entry.mBufferOffset;
+- bgb.resource.buffer._0.size = entry.mBufferSize;
++ bgb.resource.buffer = {entry.mValue, entry.mBufferOffset, entry.mBufferSize};
+ break;
+ case SerialBindGroupEntryType::Texture:
+ bgb.resource.tag = ffi::WGPUBindingResource_TextureView;
+- bgb.resource.texture_view._0 = entry.mValue;
++ bgb.resource.texture_view = {entry.mValue};
+ break;
+ case SerialBindGroupEntryType::Sampler:
+ bgb.resource.tag = ffi::WGPUBindingResource_Sampler;
+- bgb.resource.sampler._0 = entry.mValue;
++ bgb.resource.sampler = {entry.mValue};
+ break;
+ default:
+ MOZ_CRASH("unreachable");
+