summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2019-12-06 12:07:14 +0100
committerJoan Figueras2019-12-06 12:07:14 +0100
commitc4b969693fb8fc1a733193328dae4a14529ebe7d (patch)
tree8d405fb7de61fd0562096890457eaee7ef32043d
parent28f40045e275e9efe45756d8926a662df9970ec5 (diff)
downloadaur-c4b969693fb8.tar.gz
Fixed build due to clang segfaults
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ade66a4ae68..f3b86330cf00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -134,10 +134,10 @@ build() {
# LTO needs more open files
ulimit -n 4096
- # -fno-plt with cross-LTO causes obscure LLVM errors
- # LLVM ERROR: Function Import: link error
- #CFLAGS="${CFLAGS/-fno-plt/}"
- #CXXFLAGS="${CXXFLAGS/-fno-plt/}"
+ # march cannot be tuned, otherwise clang segfaults
+ CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt"
+ CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt"
+ LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
xvfb-run -a -n 97 -s "-screen 0 1600x1200x24" ./mach build
./mach buildsymbols