summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViachaslau Khalikin2021-09-03 11:30:34 +0300
committerViachaslau Khalikin2021-09-03 11:30:41 +0300
commit7b3bd7111ccfb74fbef5507bf1dcf61c9ec7e5a8 (patch)
tree693f4b6a3ada41b0e2f8613985069dc7638811c0
parent9bb3c9fee8eb228e6463fc8c37b99bb1bcf5fec9 (diff)
downloadaur-7b3bd7111ccfb74fbef5507bf1dcf61c9ec7e5a8.tar.gz
bump to 1.37.2
change to build from sources
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 27 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb691ae462c4..8d445101d1ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = icecat-ublock-origin
pkgdesc = Efficient blocker add-on for various browsers. Fast, potent, and lean
- pkgver = 1.33.2
+ pkgver = 1.37.2
pkgrel = 1
url = https://github.com/gorhill/uBlock
arch = any
groups = icecat-addons
license = GPL3
- noextract = uBlock0_1.33.2.firefox.xpi
- source = https://github.com/gorhill/uBlock/releases/download/1.33.2/uBlock0_1.33.2.firefox.xpi
- sha256sums = aa9b9f1e8fe68742d31c602ba5ad726423c058f031d6499159c8db9ec1ebeea5
+ makedepends = git
+ makedepends = python
+ makedepends = strip-nondeterminism
+ makedepends = zip
+ source = git+https://github.com/gorhill/uBlock.git#commit=1.37.2?signed
+ source = git+https://github.com/uBlockOrigin/uAssets.git
+ validpgpkeys = 603B28AA5D6CD687A554347425E1490B761470C2
+ b2sums = SKIP
+ b2sums = SKIP
pkgname = icecat-ublock-origin
-
diff --git a/PKGBUILD b/PKGBUILD
index dd3102a928e3..4e41d7cad5c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,30 @@
-# Maintainer: Viachaslau Khalikin <khalikin'at'yandex>
+# Maintainer: Viachaslau Khalikin <khalikin@yandex.by>
pkgname=icecat-ublock-origin
-pkgver=1.33.2
+pkgver=1.37.2
pkgrel=1
pkgdesc='Efficient blocker add-on for various browsers. Fast, potent, and lean'
arch=('any')
url=https://github.com/gorhill/uBlock
license=('GPL3')
groups=('icecat-addons')
-source=("https://github.com/gorhill/uBlock/releases/download/${pkgver}/uBlock0_${pkgver}.firefox.xpi")
-noextract=("${source##*/}")
-sha256sums=('aa9b9f1e8fe68742d31c602ba5ad726423c058f031d6499159c8db9ec1ebeea5')
+makedepends=('git' 'python' 'strip-nondeterminism' 'zip')
+source=("git+$url.git#commit=$pkgver?signed"
+ "git+https://github.com/uBlockOrigin/uAssets.git")
+b2sums=('SKIP'
+ 'SKIP')
+validpgpkeys=('603B28AA5D6CD687A554347425E1490B761470C2') # Raymond Hill <rhill@raymondhill.net>
+
+build() {
+ cd uBlock
+ ./tools/make-firefox.sh all
+ strip-nondeterminism -t zip dist/build/uBlock0.firefox.xpi
+}
package() {
- install -Dm644 "${source##*/}" "$pkgdir"/usr/lib/icecat/browser/extensions/uBlock0@raymondhill.net.xpi
+ cd uBlock/dist/build
+ install -Dm644 uBlock0.firefox.xpi \
+ "$pkgdir"/usr/lib/icecat/browser/extensions/uBlock0@raymondhill.net.xpi
}
# vim:set ft=sh ts=2 sw=2 et: