summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Mertz2018-06-14 12:56:35 -0500
committerTimothy Mertz2018-06-14 12:56:35 -0500
commit415096ca18a98f13df48f81021efed7d57a7755a (patch)
treedd9d68f6d2bcc22c28851c6853d927a314b71200
downloadaur-415096ca18a98f13df48f81021efed7d57a7755a.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4c5b0cb2308
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = icecream-sundae-git
+ pkgdesc = A commandline monitor for Icecream. Git version.
+ pkgver = df4240e
+ pkgrel = 1
+ url = https://github.com/JPEWdev/icecream-sundae
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = meson
+ makedepends = gcc
+ makedepends = automake
+ makedepends = pkgconfig
+ depends = icecream
+ source = icecream-sundae-git::git+https://github.com/JPEWdev/icecream-sundae
+ sha512sums = SKIP
+
+pkgname = icecream-sundae-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7fae0a8a1d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Timothy Mertz <mertzt89@gmail.com>
+
+pkgname="icecream-sundae-git"
+pkgver=df4240e
+pkgrel=1
+pkgdesc="A commandline monitor for Icecream. Git version."
+arch=('i686' 'x86_64')
+url="https://github.com/JPEWdev/icecream-sundae"
+license=('GPL2')
+depends=('icecream')
+makedepends=('git' 'meson' 'gcc' 'automake' 'pkgconfig')
+source=("${pkgname}::git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --always | sed 's/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ meson --buildtype release --prefix /usr build
+ ninja -C build
+}
+
+check() {
+ cd "${pkgname}"
+ ninja -C build test
+}
+
+package() {
+ cd "${pkgname}"
+ DESTDIR="$pkgdir/" ninja -C build install
+}
+