summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Lundberg2015-09-02 14:26:21 +0200
committerEmil Lundberg2015-09-18 17:15:04 +0200
commit5710865d5df8beb605d54b969cec8083ee5e5859 (patch)
treea4baef3dc8c65646e5b09be8d675461f078801b0
downloadaur-5710865d5df8beb605d54b969cec8083ee5e5859.tar.gz
Initial commit: Fork official extra/icedtea-web
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD89
-rw-r--r--install_icedtea-web.sh11
3 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95e8966af9dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = icedtea-web
+ pkgver = 1.6
+ pkgrel = 1
+ url = http://icedtea.classpath.org/wiki/IcedTea-Web
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = java-environment-openjdk
+ makedepends = zip
+ makedepends = libxtst
+ makedepends = npapi-sdk
+ makedepends = rhino
+ makedepends = junit
+ makedepends = firefox
+ makedepends = epiphany
+ optdepends = rhino: for using proxy auto config files
+ noextract = icedtea-web-1.6.tar.gz
+ source = http://icedtea.classpath.org/download/source/icedtea-web-1.6.tar.gz
+ sha256sums = 169386ad8d43c51b0c23ef128f9ba99040d23d9ceec24d7429514576778e117d
+
+pkgname = icedtea-web
+ pkgdesc = Free web browser plugin to run applets written in Java and an implementation of Java Web Start
+ install = install_icedtea-web.sh
+ depends = java-runtime-openjdk
+ depends = desktop-file-utils
+ provides = java-web-start
+ replaces = icedtea-web-java7
+
+pkgname = icedtea-web-doc
+ pkgdesc = icedtea-web browser plugin + Java WebStart - documentation files
+ replaces = icedtea-web-java7-doc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf4114619556
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,89 @@
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
+
+pkgbase=icedtea-web
+pkgname=('icedtea-web' 'icedtea-web-doc')
+pkgver=1.6
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://icedtea.classpath.org/wiki/IcedTea-Web'
+license=('GPL2')
+makedepends=('java-environment-openjdk' 'zip' 'libxtst' 'npapi-sdk' 'rhino' 'junit'
+ 'firefox' 'epiphany')
+optdepends=('rhino: for using proxy auto config files')
+# Due to broken path names in the tarball that fails with LANG=C in our chroot
+noextract=${pkgbase}-${pkgver}.tar.gz
+source=(http://icedtea.classpath.org/download/source/${pkgbase}-${pkgver}.tar.gz)
+sha256sums=('169386ad8d43c51b0c23ef128f9ba99040d23d9ceec24d7429514576778e117d')
+
+prepare() {
+ cd "${srcdir}"
+ LANG=en_US.UTF-8 bsdtar -x -f "${srcdir}"/${pkgbase}-${pkgver}.tar.gz
+}
+
+build() {
+ cd "${srcdir}"/${pkgbase}-${pkgver}
+ ./configure \
+ --prefix=/usr/share/${pkgbase} \
+ --datarootdir=/usr/share \
+ --with-jdk-home=/usr/lib/jvm/default \
+ --with-jre-home=/usr/lib/jvm/default-runtime \
+ --with-java=/usr/bin/java \
+ --with-browser-tests \
+ --with-firefox=/usr/bin/firefox \
+ --with-epiphany=/usr/bin/epiphany
+ make
+}
+
+#check() {
+# cd "${srcdir}"/${pkgbase}-${pkgver}
+# # as more tests have been added some are expectged to fail
+# # see http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2012-March/017566.html
+# make -k check
+#}
+
+
+package_icedtea-web() {
+
+ pkgdesc='Free web browser plugin to run applets written in Java and an implementation of Java Web Start'
+ depends=('java-runtime-openjdk' 'desktop-file-utils')
+ provides=('java-web-start')
+ replaces=('icedtea-web-java7')
+ install=install_${pkgname}.sh
+
+ cd "${srcdir}"/${pkgbase}-${pkgver}
+ # possible make target (see bottom of Makefile.am: install-exec-local install-data-local
+ make DESTDIR="${pkgdir}" install-exec-local install-data-local
+
+ # Install desktop files.
+ install -m 755 -d "${pkgdir}"/usr/share/{applications,pixmaps}
+ install -m 644 javaws.png "${pkgdir}"/usr/share/pixmaps
+ install -m 644 {javaws,itweb-settings}.desktop "${pkgdir}"/usr/share/applications
+ # remove splitted doc files
+ rm -rf "${pkgdir}"/usr/share/doc
+
+ # link binaries into /usr/bin + jre/bin
+ install -m 755 -d "${pkgdir}"/usr/bin
+ pushd "${pkgdir}"/usr/share/${pkgbase}/bin
+ for file in *; do
+ ln -sf /usr/share/${pkgbase}/bin/${file} "${pkgdir}"/usr/bin
+ done
+ popd
+
+ # link the mozilla-plugin - test it here http://www.java.com/en/download/help/testvm.xml
+ install -m 755 -d "${pkgdir}"/usr/lib/mozilla/plugins/
+ ln -sf /usr/share/${pkgbase}/lib/IcedTeaPlugin.so "${pkgdir}"/usr/lib/mozilla/plugins/
+}
+
+package_icedtea-web-doc() {
+
+ pkgdesc='icedtea-web browser plugin + Java WebStart - documentation files'
+ replaces=('icedtea-web-java7-doc')
+
+ cd "${srcdir}"/${pkgbase}-${pkgver}
+ make DESTDIR="${pkgdir}" install-data-local
+ # remove javaws about and man page
+ rm -rf "${pkgdir}"/usr/lib
+ rm -rf "${pkgdir}"/usr/share/man
+ rm -rf "${pkgdir}"/usr/share/icedtea-web # conflicting and unneeded file it seems
+}
diff --git a/install_icedtea-web.sh b/install_icedtea-web.sh
new file mode 100644
index 000000000000..80312d4a6041
--- /dev/null
+++ b/install_icedtea-web.sh
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}