summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Lundberg2015-09-18 17:02:29 +0200
committerEmil Lundberg2015-09-18 17:15:22 +0200
commit5f12451a02ab0627cb24ca630b2ab655ac9a0956 (patch)
treebdb4e958c93c01740911e0587ba6809488361c57
parent78f1b106f55e931a97b2e4cf4dc5b4d2e166fa9c (diff)
downloadaur-5f12451a02ab0627cb24ca630b2ab655ac9a0956.tar.gz
Add patch for broken package-info.java
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--fix-package-info.patch12
3 files changed, 22 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c1134bc471c..db705243276c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,7 +19,9 @@ pkgbase = icedtea-web
conflicts = icedtea-web
noextract = icedtea-web-1.6.1.tar.gz
source = http://icedtea.classpath.org/download/source/icedtea-web-1.6.1.tar.gz
+ source = fix-package-info.patch
sha256sums = a9b46ab6c9dc303c89651143596bc5abea29242b9bdcabdd2dab7c606592c920
+ sha256sums = 3da531a0b2ba99152fe9410591ade01b6ea63a926cc36f3fa0ab39955708940c
pkgname = icedtea-web-jre32
pkgdesc = Free web browser plugin to run applets written in Java and an implementation of Java Web Start
diff --git a/PKGBUILD b/PKGBUILD
index 1ee2e146ea6f..fd38a01617e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,12 +15,18 @@ makedepends=('java-environment-openjdk' 'zip' 'libxtst' 'npapi-sdk' 'rhino' 'jun
optdepends=('rhino: for using proxy auto config files')
# Due to broken path names in the tarball that fails with LANG=C in our chroot
noextract=${pkgbase}-${pkgver}.tar.gz
-source=(http://icedtea.classpath.org/download/source/${pkgbase}-${pkgver}.tar.gz)
-sha256sums=('a9b46ab6c9dc303c89651143596bc5abea29242b9bdcabdd2dab7c606592c920')
+source=(
+ http://icedtea.classpath.org/download/source/${pkgbase}-${pkgver}.tar.gz
+ fix-package-info.patch
+)
+sha256sums=('a9b46ab6c9dc303c89651143596bc5abea29242b9bdcabdd2dab7c606592c920'
+ '3da531a0b2ba99152fe9410591ade01b6ea63a926cc36f3fa0ab39955708940c')
prepare() {
cd "${srcdir}"
LANG=en_US.UTF-8 bsdtar -x -f "${srcdir}"/${pkgbase}-${pkgver}.tar.gz
+
+ patch "${srcdir}/${pkgbase}-${pkgver}/netx/net/sourceforge/jnlp/security/package-info.java" fix-package-info.patch
}
build() {
diff --git a/fix-package-info.patch b/fix-package-info.patch
new file mode 100644
index 000000000000..7ba1272d8748
--- /dev/null
+++ b/fix-package-info.patch
@@ -0,0 +1,12 @@
+50c50
+< | >------------------------------------> | <----------------------------------------------------------------------------------------------------------------------------| X
+---
+> | -------------------------------------- | -----------------------------------------------------------------------------------------------------------------------------| X
+70c70
+< | --> set selected value (via listener?) to message, dispose dialog --| | X
+---
+> | --- set selected value (via listener?) to message, dispose dialog --| | X
+73c73
+< | <------------------------------------------------------------------------------------------< unlock lock of this messge >--------------------------------------------| X
+---
+> | ------------------------------------------------------------------------------------------ unlock lock of this messge --------------------------------------------| X