summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Lundberg2015-09-18 17:21:27 +0200
committerEmil Lundberg2015-09-18 17:21:27 +0200
commitafd2ae88563b40a2bccf713501f2291fcdfd7d7e (patch)
tree130828a1c7750f26a37615e450d56a1ce7a5a036
parent5f12451a02ab0627cb24ca630b2ab655ac9a0956 (diff)
downloadaur-afd2ae88563b40a2bccf713501f2291fcdfd7d7e.tar.gz
Set pkgbase=icedtea-web-jre32 as AUR expects
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD27
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db705243276c..1d45bbd12d57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = icedtea-web
+pkgbase = icedtea-web-jre32
pkgver = 1.6.1
pkgrel = 1
url = http://icedtea.classpath.org/wiki/IcedTea-Web
diff --git a/PKGBUILD b/PKGBUILD
index fd38a01617e7..08a1362e3067 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
-pkgbase=icedtea-web
+_pkgbase=icedtea-web
+pkgbase=icedtea-web-jre32
pkgname=('icedtea-web-jre32' 'icedtea-web-doc')
conflicts=('icedtea-web')
pkgver=1.6.1
@@ -14,9 +15,9 @@ makedepends=('java-environment-openjdk' 'zip' 'libxtst' 'npapi-sdk' 'rhino' 'jun
'firefox' 'epiphany')
optdepends=('rhino: for using proxy auto config files')
# Due to broken path names in the tarball that fails with LANG=C in our chroot
-noextract=${pkgbase}-${pkgver}.tar.gz
+noextract=${_pkgbase}-${pkgver}.tar.gz
source=(
- http://icedtea.classpath.org/download/source/${pkgbase}-${pkgver}.tar.gz
+ http://icedtea.classpath.org/download/source/${_pkgbase}-${pkgver}.tar.gz
fix-package-info.patch
)
sha256sums=('a9b46ab6c9dc303c89651143596bc5abea29242b9bdcabdd2dab7c606592c920'
@@ -24,15 +25,15 @@ sha256sums=('a9b46ab6c9dc303c89651143596bc5abea29242b9bdcabdd2dab7c606592c920'
prepare() {
cd "${srcdir}"
- LANG=en_US.UTF-8 bsdtar -x -f "${srcdir}"/${pkgbase}-${pkgver}.tar.gz
+ LANG=en_US.UTF-8 bsdtar -x -f "${srcdir}"/${_pkgbase}-${pkgver}.tar.gz
- patch "${srcdir}/${pkgbase}-${pkgver}/netx/net/sourceforge/jnlp/security/package-info.java" fix-package-info.patch
+ patch "${srcdir}/${_pkgbase}-${pkgver}/netx/net/sourceforge/jnlp/security/package-info.java" fix-package-info.patch
}
build() {
- cd "${srcdir}"/${pkgbase}-${pkgver}
+ cd "${srcdir}"/${_pkgbase}-${pkgver}
./configure \
- --prefix=/usr/share/${pkgbase} \
+ --prefix=/usr/share/${_pkgbase} \
--datarootdir=/usr/share \
--with-jdk-home=/usr/lib32/jvm/default \
--with-jre-home=/usr/lib32/jvm/default-runtime \
@@ -44,7 +45,7 @@ build() {
}
#check() {
-# cd "${srcdir}"/${pkgbase}-${pkgver}
+# cd "${srcdir}"/${_pkgbase}-${pkgver}
# # as more tests have been added some are expectged to fail
# # see http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2012-March/017566.html
# make -k check
@@ -59,7 +60,7 @@ package_icedtea-web-jre32() {
replaces=('icedtea-web-java7')
install=install_${pkgname}.sh
- cd "${srcdir}"/${pkgbase}-${pkgver}
+ cd "${srcdir}"/${_pkgbase}-${pkgver}
# possible make target (see bottom of Makefile.am: install-exec-local install-data-local
make DESTDIR="${pkgdir}" install-exec-local install-data-local
@@ -72,15 +73,15 @@ package_icedtea-web-jre32() {
# link binaries into /usr/bin + jre/bin
install -m 755 -d "${pkgdir}"/usr/bin
- pushd "${pkgdir}"/usr/share/${pkgbase}/bin
+ pushd "${pkgdir}"/usr/share/${_pkgbase}/bin
for file in *; do
- ln -sf /usr/share/${pkgbase}/bin/${file} "${pkgdir}"/usr/bin
+ ln -sf /usr/share/${_pkgbase}/bin/${file} "${pkgdir}"/usr/bin
done
popd
# link the mozilla-plugin - test it here http://www.java.com/en/download/help/testvm.xml
install -m 755 -d "${pkgdir}"/usr/lib/mozilla/plugins/
- ln -sf /usr/share/${pkgbase}/lib/IcedTeaPlugin.so "${pkgdir}"/usr/lib/mozilla/plugins/
+ ln -sf /usr/share/${_pkgbase}/lib/IcedTeaPlugin.so "${pkgdir}"/usr/lib/mozilla/plugins/
}
package_icedtea-web-doc() {
@@ -88,7 +89,7 @@ package_icedtea-web-doc() {
pkgdesc='icedtea-web browser plugin + Java WebStart - documentation files'
replaces=('icedtea-web-java7-doc')
- cd "${srcdir}"/${pkgbase}-${pkgver}
+ cd "${srcdir}"/${_pkgbase}-${pkgver}
make DESTDIR="${pkgdir}" install-data-local
# remove javaws about and man page
rm -rf "${pkgdir}"/usr/lib