summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Merry2015-06-14 19:17:35 +0100
committerAlex Merry2015-06-14 19:17:49 +0100
commitbc8053ce6b4b527b5609aa45f7f3a35cfc3cf782 (patch)
tree3e82acbec4d4abd67e8327a4fc532c7df5e73803
downloadaur-bc8053ce6b4b527b5609aa45f7f3a35cfc3cf782.tar.gz
Import from AUR 3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9cefbc8f87c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = icemon
+ pkgdesc = Icecream GUI monitor.
+ pkgver = 3.0.0
+ pkgrel = 2
+ url = https://github.com/icecc/icemon
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = docbook2x
+ depends = icecc
+ depends = qt5-base>=5.2
+ provides = icemon
+ conflicts = icemon-git
+ source = https://github.com/icecc/icemon/archive/v3.0.0.tar.gz
+ md5sums = 7ba23d812db4bdd32d52e947c5749217
+
+pkgname = icemon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aaac1174dde0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Alex Merry <alexmerry@kde.org>
+
+pkgname='icemon'
+pkgver=3.0.0
+pkgrel=2
+pkgdesc='Icecream GUI monitor.'
+url='https://github.com/icecc/icemon'
+license=('GPL')
+depends=('icecc' 'qt5-base>=5.2')
+# docbook2x required for man page generation
+makedepends=('cmake' 'docbook2x')
+provides=('icemon')
+conflicts=('icemon-git')
+arch=('i686' 'x86_64')
+source=('https://github.com/icecc/icemon/archive/v3.0.0.tar.gz')
+md5sums=('7ba23d812db4bdd32d52e947c5749217')
+
+build() {
+ mkdir -p build
+ cd build
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -D_docbook_to_man_executable=/usr/bin/docbook2man \
+ "../${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd build
+
+ make DESTDIR="${pkgdir}" install
+}