summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorianux2015-06-10 13:01:40 +0200
committerianux2015-06-10 13:01:40 +0200
commit29130354b5950d75016ad8aae725e1893f086c95 (patch)
tree4cc52be8061884069e3774451605bf40ab60bbec
downloadaur-29130354b5950d75016ad8aae725e1893f086c95.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
-rw-r--r--ices0.install8
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9c05d2d4705
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = ices0
+ pkgdesc = Source client for broadcasting in MP3 format to an Icecast2 server
+ pkgver = 0.4
+ pkgrel = 1
+ url = http://icecast.org/ices.php
+ install = ices0.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxml2
+ depends = lame
+ depends = libvorbis
+ depends = libshout
+ depends = python2
+ depends = perl
+ options = !docs
+ source = http://downloads.us.xiph.org/releases/ices/ices-0.4.tar.gz
+ md5sums = d31450c4011561dae0229f071cb41cb6
+ sha1sums = 427f39d3ac4a45e84222c8f8a4007767a754749c
+
+pkgname = ices0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f683a643e36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: ianux <ianux at free dot fr>
+# Contributor: priyank
+
+pkgname=ices0
+_pkgname=ices
+pkgver=0.4
+pkgrel=1
+pkgdesc="Source client for broadcasting in MP3 format to an Icecast2 server"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://icecast.org/ices.php"
+depends=('libxml2' 'lame' 'libvorbis' 'libshout' 'python2' 'perl')
+source=(http://downloads.us.xiph.org/releases/$_pkgname/$_pkgname-$pkgver.tar.gz)
+md5sums=('d31450c4011561dae0229f071cb41cb6')
+sha1sums=('427f39d3ac4a45e84222c8f8a4007767a754749c')
+options=('!docs')
+install=$pkgname.install
+
+build() {
+ cd ${srcdir}/$_pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/usr/share/$pkgname -mandir=/usr/share \
+ --with-python=/usr/bin/python2 --without-faad --without-flac
+ make
+}
+
+package() {
+ cd ${srcdir}/$_pkgname-$pkgver
+ make DESTDIR=${pkgdir} install
+ # Rename files to avoid conflict with ices2
+ mv ${pkgdir}/usr/bin/ices ${pkgdir}/usr/bin/ices0
+ mv ${pkgdir}/usr/share/man1/ices.1 ${pkgdir}/usr/share/man1/ices0.1
+ install -Dm644 COPYING ${pkgdir}/usr/share/licenses/$pkgname/COPYING
+}
diff --git a/ices0.install b/ices0.install
new file mode 100644
index 000000000000..a4519683dfb0
--- /dev/null
+++ b/ices0.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "To avoid conflict with ices2, ices binary has been renamed to ices0 (so as man page)"
+ echo "and sample config files have been installed in /usr/share/ices0."
+}
+
+post_upgrade() {
+ post_install $1
+}